Jump to content

Archived

This topic is now archived and is closed to further replies.

wpchannel

Translating WhiteHousePro

Recommended Posts

wpchannel

Hi,

 

I'm using a child theme with /language folder but the translations are not working. I think it was working fine the first time but not anymore...

Share this post


Link to post
Share on other sites
Danny

HI,

Can you provide a link to the site in question and also provide the exact steps you took when translating your site.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
wpchannel

HI,

Can you provide a link to the site in question and also provide the exact steps you took when translating your site.

 

Sure here is the link : http://allezlestademontois.fr/

 

I simply open POT file from DMS/language and create fr_FR.po / mo with Poedit. I tried then to paste them in the child theme.

Share this post


Link to post
Share on other sites
Danny

Have you changed the language in your WordPress ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Unfortunately, we are unable to proceed providing support as you have renamed the dms directory to smr2. By doing this you void all support as the dms folder structure needs to be dms/dms/.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
wpchannel

I have gone back to default structure and the problem remains...

Share this post


Link to post
Share on other sites
Danny

Can you please provide screenshots so we can see what isn't translated please. Also screenshots of your child theme structure i.e. child theme folder and language folder.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
wpchannel

Yes sure!

 

In attachment, a screenshot with strings like: "continue reading", "by", "edit". 

 

Capture-d%E2%80%99%C3%A9cran-2014-11-06-

 

In a second attachment, my child theme structure.

 

Capture-d%E2%80%99%C3%A9cran-2014-11-06-

Share this post


Link to post
Share on other sites

  • Similar Content

    • elombard
      By elombard+
      Hello,
       
      After posting at the end of a thread that is more than a year old, I realized it did not bump up my question in the front page of the forum, so I've decided to post it as a new topic, which it is.
       
      I did just as said in the following thread:
      http://forum.pagelines.com/topic/16971-how-to-change-a-text-string-with-poedit/
       
      - I installed the pagelines-customize plug-in, activated it, and created a language subfolder.
      - I used Poedit to edit my fr_FR.po file and copied the output fr_FR.po and fr_FR.mo files to wp-content/plugins/pagelines-customize/language.
       
      After that, my new translation (the hover text for the Flipper section) is not displayed. I tried refreshing the cache to no avail.
       
      However, after I overwrote the original fr_FR.po and fr_FR.mo files with the modified ones in wp-content/themes/dms/language, it works right away. So you may wonder, why do I post a question?
       
      Well, I had to change directly the DMS theme to make it work, while the customize plug-in remains useless, which means that I will lose my custom translation after the next DMS update which will overwrite files in wp-content/themes/dms.
       
      Can you please help and fix the customize plug-in?
       
      Best regards,
      E.L.
×