Jump to content

Archived

This topic is now archived and is closed to further replies.

Claude203

Glitch with Multiple Popups using Modal Popup DMS?

Recommended Posts

Claude203

Thanks in advance for your help on this.

 

I need some help setting up an additional Modal Popup that activates on a specific page. Having read these instructions below, I am still confused:

 

There’s no limit to the number of PopUps you can put on your site. If you want to show a different PopUp on a particular page, just go into the Section Options for that page, create your PopUp, and assign a custom name to your cookie.

 

This way, if the default cookie has already been set in your visitor’s browser, your second PopUp will still appear using the new cookie.

 

Maybe I am misreading but are these instructions saying that it is possible to create a new Modal Popup from within the Section Options, while the original Modal Popup continues to exist unchanged? I'm not able to figure out how to do that. In other words, where is the "Create New Modal Popup" button/selection?

 

Otherwise, whatever changes I make to the PopUp for that particular page, is now visible on all pages. I thought that the changes would be specific to the Popup that pops up on just that page.

 

Thank you very much!


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Danny

HI Claude,

 

You topic is related to a third party store extension. PageLines do not provide support for these extension and therefore, you need to make sure in future that you post your topic in the correct forum.

I have moved your topic to the correct location and MrFent mentioned the developer who will assist you.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Claude203

Thank you Danny. Sorry for the misplacement. I wasn't sure but now I know.


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
MrFent

Hi Claude, what type of page are you trying to display the 2nd PopUp on? whatever is in the section options is what will appear on that page. If you are trying to create a popup on a post, you would need to alter that post's template setup. Please give me more detailed info on exactly what you want to place where.

Share this post


Link to post
Share on other sites
Claude203

OK, thanks. And this may just be me misunderstanding the instructions. When I go to that page where I want a page-specific popup, I select the preview/edit selector, I see the admin notice for the placeholder for the main Modal PopUp section. Should I then just simply add another one? Is it that simple? In other words, if I want a page-specific popup I would NOT change the existing one but rather ADD a new one, with its own custom name, etc. Correct? I think that was the mixup, if that is the case.

 

PS–In other words, one can add as many Modal PopUp sections as they wish, to any page/post, right?


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
MrFent

Where on the page are you placing the popup? Is it in a global area like the header and footer? if so, it will affect the popup on every page.  your popup section needs to be placed in a template area that is unique to that page

Share this post


Link to post
Share on other sites
Claude203
Ah! Thanks for that last point! That's a question I had not considered and it raises other questions.

I would place the Popup section above the footer on a page. Then again, if all of our pages have unique content but use the same page template, would adding the pop up section above the footer change the page template everywhere?

Similarly, all of our blog posts are unique in content but share the same post template. Would adding the pop up above the footer change every post that uses that template?

Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
MrFent

Just think of it as you would any DMS section. If it's in the footer or header, it's going to be the same anywhere. If it's in the middle area, but that page is linked to a template, it's going to appear on all the other pages linked to that same template. No different than any other DMS section. If you want to add a popup to a blog post, you would need to do the same thing that you would do for any blog post with a unique section: Go to the front end of that blog post, go to your DMS toolbar, click on Page Setup, then Page handling. then select the dropdown and change it from Type to Local. this will set that post apart from the rest of your blog posts and you can add unique sections to that post without them appearing on all your other blog posts 

Share this post


Link to post
Share on other sites
Claude203

Thanks for your reply. I'm not a complete DMS expert yet so I just learned something new regarding the Page Handling section. This effort is in regard to a page.

 

You're right, the Modal Popup now shows up on every single page with that page template. 

 

Following your instructions since this page in question is linked to a template, I would like to unlink it. However, I ran into an obstacle. In the Page Handling section that page is already listed as "LOCAL" but yet there is a Template ID being used with it. So how do I unlink it? I tried switching to TYPE and back again, but that didn't work. I could save the page to a new template but that does not seem to be how DMS was intended to be used. I also went into the page's HTML editor and tried to change the DMS Page Setup from there but the choices are the same as in Page Handling, nothing to de-link to local. Thanks.


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
MrFent

From the DMS toolbar, toggle the preview, then go to the top of the template area and click the text with the Template name.

 

http://screencast.com/t/Icwc0nms0

 

Before you unlock that page from the template, you would first want to remove the popup, so that it won't remain attached to the template on the other pages. Then once you unlink the page from the template, add the popup back.

Share this post


Link to post
Share on other sites
Claude203

That worked perfectly! Thank you! 

 

Just to recap: The section has to be unlocked first, before adding the Modal Popup or else the popup with show up on all the pages/posts that share that same page template. And vice versa, if you want to remove all occurrences of a Modal Popup from a given page template then you have to remove it prior to unlocking. 

 

Again, thank you very much!

 

This is a very powerful, elegant, and easy to use add-on.


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites

  • Similar Content

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
×