Jump to content

Archived

This topic is now archived and is closed to further replies.

Claude203

How to Properly Place Modal Popup Link in Main Menu with Custom Link

Recommended Posts

Claude203

I would like to learn how to place a modal popup link into our mail menu, with the twist that I would like it preceded by an icon and for the text to remain on the same line.

 

Here is what I am using now:

 

URL: http://www.blackfives.org/join

Navigation Label: <i class="icon icon-envelope-alt"></i> Join

 

Here is what works using the Custom Link menu option in one of the footer widgets:

 

URL: Blank

Navigation Label: <i class="icon icon-envelope-alt"></i> <a href="#ModalPopUp" data-toggle="modal">Join Our Email List</a>

 

But for some reason this does not work in my Main Menu:

 

URL: Blank

Navigation Label: <i class="icon icon-envelope-alt"></i><a href="#ModalPopUp" data-toggle="modal"> Join</a>

 

The problem is that this puts the word "Join" directly below the envelope icon.

 

Another way of asking this question would be ... is there any way to supply an actual URL (not an href) that could be used in the URL field, but yet could still call the modal popup?

 

Thank you!


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Danny

Hi Claude,

 

Yeah that isn't going to work, as the navigation label has no control over how the menu link works. If you want to create a modal via a menu item, you're going to likely need to use custom code or a lightbox style plugin that uses classes to generate the modal popup. I recommend you ask this question on the WordPress support forums, as you're using the WordPress menu system.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Claude203

Thank you.


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites
Aldo

Claude203 from my understanding you wanted to create a link button that triggers the popup email capture "Modal Popup DMS" plugin, did you get to work?

 

I am interested in the plugin and need that feature

Share this post


Link to post
Share on other sites
Claude203

Aldo, it definitely works. The only time it doesn't work, and this was why I posted the question, is when the link is in the specific main navigation menu that I happen to be using. It works fine in the sidebar and in the footer menu. My workaround is that I made the main menu link go to a page with a full "join our list" form, while the popups are just quick name and email forms. You could see what I mean by heading over the our website and looking for instances of the word "Join" in the header menu, sidebar button, and footer menu. The popup as well. 


Claude Johnson
BlackFives.org

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • mtaus
      By mtaus+
      Just did a clean install of Platform 5 at myedadvisor.com and the icons in Pagelines are not displaying (screenshot attached).

    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

×