Jump to content

Archived

This topic is now archived and is closed to further replies.

lazlo

Content Width Rev Slider?

Recommended Posts

lazlo

Hi, Has anyone created a content-width Rev Slider?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

There is no content width RevSlider. However, I have just made you one on my GitHub repo.

 

  1. Simply download and extract the zip.
  2. Rename the directory to revslider
  3. Then upload it to your child themes section folder directory
  4. If you have no child theme, use the PL Starter Theme or my Skeleton advanced theme, which contains a sections directory already.
  5. Once uploaded to the sections folder in the child theme, go to your site and make sure your child theme is the active theme.
  6. Then go to DMS Toolbar > Add to Page and click Reload Sections.
  7. Upon refresh, there should be two RevSliders.

 

https://cloudup.com/cE5wnn8zgj0

 

https://github.com/Dannyholt/dual-width-revslider

http://dannyholt.github.io/skeleton/

 

Please be aware that if you encounter any issues, that no support can be provided, as the section is only full-width by default.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
lazlo

Danny, you're a legend!...I did check your Github incase you'd already made one ;o)

 

thanks again

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Bleuy

Thats ACE Danny, just what I was looking for.  Don't suppose you have an optimum image dimension do you, the full size one is 2000 x 800 :0)

Share this post


Link to post
Share on other sites
sheilahoff

Excellent. I'll go grab this too. But I'm SURE there used to be two RevSliders in the "old" days...didn't there?!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Aires

Awesome @Danny  :thumbsu:


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Simon

Excellent. I'll go grab this too. But I'm SURE there used to be two RevSliders in the "old" days...didn't there?!

I think quickslider was dual width wasnt it?

Share this post


Link to post
Share on other sites
sheilahoff

I don't know about QuickSlider but RevSlider was definitely offered as both in the past. I just looked at some of my old DMS1 sites. But the new download worked a treat! Now I just have to go find my old notes about how to tweak it (get rid of the moving bar that times the slides, etc).


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

RevSlider as far as I can remember has always been full-width, the only time it can be content width is when you use box mode.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Hopefully you won't yell at me for asking this here. If you prefer I can start a new topic. I'm using your wonderful content width slider. The client said the images (which as 940x450 were being enlarged and distorted. He wanted the whole site narrower. I've made it narrower but the images are not adjusting to the narrower width. Now they're cutting off the edges. I'm not sure if I need to re-save these images to a new size or if there's css to set their size or what I'm supposed to do. They're here: http://perfect-image.flywheelsites.com/The first slide looks OK but you can see on the second one it's cropping off some of the text. What is the appropriate way to make this work properly? Thanks.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

sheilahoff

 

Try this:

 

#site .tp-bgimg {
  background-size: 100% 100% !important;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Danny you d'best! I hope they pay you well! It resizes BUT...is there a way to eliminate the little jump each time as it resizes? I know...picky picky!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

The only way to remove this resize jump, would be to edit the section code. What I would suggest is you create a child of RevSlider and then edit the core so that it no longer uses cover, but instead uses background-size: 100% 100%;


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Brilliant...can do!

 

LOL...oops...I just realized I'm not even sure which file you mean to edit never mind if I'll know where in the file to edit.  Could you possibly be more specific?! Thanks.

 

So I get that it's in the section.php. I found this line that seems to be it:

$bg = sprintf('<img src="%s" alt="" data-bgposition="center center" data-bgfit="cover" data-bgrepeat="no-repeat">', $the_bg);

 

And changed center to the code you provided both with and w/o the semi-colon. Neither works. The slides no longer show. That's the only place in the section that says cover so I must need to do it differently...

 

PS: so I changed just the word cover in that code to percentage and got the images back but they still jump. How do I get the 100% 100% in there and working? Obviously I don't code...but I AM fearless. I see a percentage sign at the beginning of the line. Maybe there?

 

PPS: I think I fixed it. With that change I needed to remove the CSS you'd provided. They must've been competing. I THINK it's fixed now. So all I did was change cover to percentage in the section code above and remove the CSS.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

What code did you end up using ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

In the section.php I used this:

 

$bg = sprintf('<img src="%s" alt="" data-bgposition="center center" data-bgfit="percentage" data-bgrepeat="no-repeat">', $the_bg);

 

with NO related CSS.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Awesome, good job Sheila!


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • stijnxo
      By stijnxo+
      The Filtering of categories in the Masonic Gallery refreshes back to ALL categories when the DMS Revslider loads a new image?
      Anybody any idea? See Artists Category refreshes back to ALL when the DMS Revslider with images on the top loads a news image on http://www.18hrsfestival.nl/
    • Jared Smith
      By Jared Smith+
      I'm trying to make a visible border around the entirety of a client's site.  Example on some other site here:
      http://www.makeyourvisionreal.com/movement

      So it is around the Title, Menu, and Content Area.  I'm having a bit of difficulty with this on pagelines, using the Framework theme. It's slightly more complex because the site has a "landing page" that doesn't need the border. Much like this homepage
      http://www.makeyourvisionreal.com/
       
      Right now I'm using a content width of 80%, and fullscreen.  But maybe thats not the best way to do it.  
       
      So, with the #site id, I can hit the whole area on most of the site, but I'm not sure how I can remove it for just one page.
      #site { border:1px solid #ccc; margin: 100px 5% 5% 50px; } anyone have any suggestions?  Maybe I need to go make a child template, not sure?  Thanks!
    • carl
      By carl+
      Trying to convert a site over to PL5 from DMS2. Can we use revslider? Can any portion of DMS2 be editable or imported through PL5?
      I'm trying to wrap my head around the new PL5 os, but things have changed so much it like learning a new software. I DO like the new UI! Great job.
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • jennajonesdesign
      By jennajonesdesign+
      Hi Guys, 
      I just went live with this site. http://bikenet.org/
      I can see the video background in Firefox, Chrome and IE on my computer as well as my husband's computer and my phone. So I am not able to see any problem. 
      But, my client says she cannot see the video background in Chrome?? Any ideas? 
      Let me know. Thanks!
       
      Jenna
×