Jump to content

Archived

This topic is now archived and is closed to further replies.

TedWada

change affects to other templates

Recommended Posts

TedWada

I use DMS 2.1.7 and am having a serious problem.

 

When I edit a content in the item (ex. iBox), it affects to same item in other template page. For example, if I change a content in the iBox in the template A, the change affects to the iBox in the template B. This occurs not only iBox but iCallout, as well.

 

Why this happens and how I avoid? Because of this, I cannot create a page.

 

Thanks,

 

Ted

Share this post


Link to post
Share on other sites
Danny

HI Ted,

 

It is likely that you have added these sections to your header region. The header region is a global region, meaning that any sections added to this region will be displayed throughout the site.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
TedWada

Thanks for reply. However, the header region doesn't have any items. The iBox I put is inside ["MY TEMPLATE" TEMPLATE (UNLOCK)]. Does it mean still my iBox is in header region? If so, how I can put the part outside there?

Share this post


Link to post
Share on other sites
Danny

OK, if you have added sections to the template region. Then what you have probably done is this:

 

Created Template A

Then loaded Template A on a different page and then saved that as Template B

Then you have proceeded to make your changes.

If this is the method you have used, then you didn't unlock the template before saving Template B.

 

So what is happening is that Template A and Template B are still linked and is the reason why you're experiencing these issues.

So in future, when you load a template on a new page and wish to create a new template, unlock that template before doing so. Once unlocked, you can make changes to sections without it affecting other templates.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
TedWada

Thanks Danny! I could resolve the problem. Yes, I created Template B from Template A without unlocking. Unlock and save cut the link between Template A and B.

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Cryptic

Hi There..

 

I'm having a very similar problem but it's not quite the same.

 

Firstly..... 

 

I have 2 pages which when i change something in 1 it does the same on the other page and vise versa.

I was hoping my problem was as simple as either being placed under a header, fixed, or footer by accident, but this is not the case.

 

I have both templates on both pages unlocked. Then saved a new template, and then unlocked it but they both seem to continue on being linked.. (I have the blue dotted line with no yellow insight) I have realized that when i unlock 1 page template (save it), then refresh the other page i find that the other page is unlocked as well. It is like they are forever linked... 

 

I almost through my laptop into my neighbors window. Please help! Any idea's would be greatly appreciated!!

Share this post


Link to post
Share on other sites
Cryptic

Just an update. I had both pages being posts, so I copied all there info and put them into a page(format), then loaded the template and unlocked it and it has worked. I just don't understand why it doesn't work in a post (format). 

 

I am only new to all this so it's probably very obvious. but if you could tell me why i'd love to know..

 

Thanks in advance!!!!

Share this post


Link to post
Share on other sites
Danny

Cryptic - Unfortunately, you can only assigned one template to all posts. It is currently not possible to have individual templates for posts. This has been reported to our issue tracker and our developers are aware of the issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Cryptic

Understood... i'm glad it wasn't me doing something terribly wrong.. I know this is a silly question but do u think it will be fixed in the future? time frame? 

 

Thank you for replying to my post!!! I appreciate it!!

Share this post


Link to post
Share on other sites
Danny

Unfortunately, we never give out ETA's on updates, as things can be put back or brought forward for whatever reason.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Cryptic

yeah... i so understand...Well thanks again for your time!!

Share this post


Link to post
Share on other sites

  • Similar Content

    • camaran
      By camaran
      In attach a new version of ContentBox for DMS
    • KristaD
      By KristaD
      Hi there,
       
      I loaded my site onto a new host last night (new domain as well) and I noticed that the Rapid Tabs section now has lines around it with a different look. I am trying to remove the lines and the way the tabbed section looks and return it to default. http://officialgenaleenolin.com.previewdns.com/
      I tried messing with CSS but nothing is happening. Thanks for your help in advance.
       
      --NOTE: I signed out and the RapidTabs section went back to normal. This is happening only when I'm signed into DMS. I also noticed my DMS control panel has some weird styling as well.
    • danmanders
      By danmanders
      Hey guys, for some reason I can't seem to figure out how to edit a ContentBox that I've placed in the footer. My current site (not built with Pagelines, I'm in the process of replacing it) shows the way I'd like the footer to look, and I know how to accomplish this with a ContentBox, but I am stuck on how to edit the actual content of that section. I was able to drag it in there in the Page Template area no problem, and I've tried putting content there using the Sitewide Defaults for the ContentBox section, but that changes other ContentBox sections I have elsewhere on the site. Anyone have some advice?
       
      The site I'm working on is http://danmanders.com
      The site I'd like to copy the footer from is http://phillydogschool.com
       
      Thank you!
    • danmanders
      By danmanders
      Hi, I've been unable to correctly reference the classes I've assigned to Content Boxes in the Custom CSS section. I learned how to adjust the individual things I want to modify (padding, margin, alignment, etc.), but all of my edits thus far have been applied site-wide to various sections or headers. Specifically, I'm trying to give the Content Box at the end of this page a negative top margin, to move it closer to the Accordion above it. The class I assigned to that Content Box is "faq". Could you please tell me exactly how to reference it? I know that I can find this information with Firebug, but I've spent the last couple of hours attempting to do so unsuccessfully.
       
      You guys market Pagelines as needing no coding knowledge whatsoever to use, which is far from the truth in anything but the simplest cases, but I'm happy to learn as I go. That said, it would be nice if you could just tell me exactly what I need to type in to reference this specific Content Box. Doing so would save me hours of frustration now, and would also give me the knowledge I need to reference other sections that I've assigned classes to. Thanks for all of your help!
×