Jump to content

Archived

This topic is now archived and is closed to further replies.

Ryan Logan

Custom CSS, Custom Scripts and Front-End Changes Not Saving

Recommended Posts

Ryan Logan

Hello.    This has been happening for quite awhile now, on pretty much all of my sites and I can't stand it anymore.   DMS is slowing me down these days and I feel like I spend most of my time double/triple-checking if my changes are being saved.  Focusing on one site at the moment:  www.tamingthemonkey.guru

 

I've read other posts re: this issue.  I don't have a caching plugin enabled and I'm not using a host that has any special caching mechanisms.  I've also tried disabling plugins.

 

 

Custom CSS/Custom Scripts

  1. I enter something in either of these sections and publish.  **I've learned to copy my entries because of #3 below
  2. The changes are not reflected on the website
  3. I go back into these sections and what I entered is no longer there
  4. I copy my entries back in and publish.
  5. Steps 2 and 3 repeat
  6. I go through the above about 4 or 5 times before the entries actually stick

Front-End/DMS (Layout Width)

  1. I drag the dotted line, to increase the width of the website margins.  I publish the changes.
  2. The changes are not reflected on the website
  3. I go back into DMS and the margins I set are reset back to the out-of-the-box margins
  4. On this particular site...the margins WILL NOT STICK at all

Front-End/DMS (Publishing Button)

 

I make changes and I click Publish.  Sometimes the radio button (not sure what you call it...Status Button perhaps.?)  turns Green right away.  Most of the time I have to hit Publish 3-4 times before the Publish button will turn the radio button Green.  This is not that bad if it happens once in awhile, but it happens ALL THE TIME and on pretty much all of  my sites.

Share this post


Link to post
Share on other sites
Simon

Have you tried the latest version?, has a fix for sites with mixed ssl.

Share this post


Link to post
Share on other sites
bloom1creative

Could pretty much mirror this post.  I have a habit now of clicking publish about 5 times, clicking off the content, publish again, etc, just to make sure.  And I also have to copy and paste every time I enter content into a front-end box incase it just vanishes on refresh.  That applies to every site I've made with the DMS since Ive used it.

 

The unique errors in recent versions are the complete loss of saved sections and template layouts, and unlocking templates or sections sometimes still edits the previous attached template.

 

I mostly am posting to make you guys aware these issues are common and do need addressing, not to annoy or spam.  Ive sat through using them and its funny that like many other users, I'e just become used to working around the bugs.

 

 


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Guest

@Simon_P:  Thank you for the quick response.  I just installed 2.1.8, which actually reminds me of another DMS/Pagelines issue.  There is no notification that a newer version of DMS or Pagelines Updater is available.  It's like the Moon or Sun has to be in the perfect position in the sky for the update to appear in the dashboard.  Hopefully 2.1.8 will make a difference, but I don't think it will based on the changelog details.

 

@bloom1creative:  Appreciate you turning up the volume on these issues.

 

Ryan

Share this post


Link to post
Share on other sites
Simon

WordPress only checks once every 24 hours for theme and plugin updates.

The updater uses the WordPress updates system.

 

2.1.8 DOES fix a lot of saving issues, for instance on wpengine, where they force wp-admin to be SSL but the frontent to be non-ssl, this confused dms, 2.1.8 fixed this issue.

The OP did not give a url or where the site is hosted so I am left to pure speculation.

Share this post


Link to post
Share on other sites
Guest

Cool, well...fingers crossed!  Just for the information, here are the hosting companies I'm currently using.

 

-GoDaddy (shared hosting)

-Bluehost (not the wordpress-optimized version)

-Flywheel

Share this post


Link to post
Share on other sites
Danny

rlogan - We are going to need more info, as you have provided a link to a site but it is behind a coming soon message.

 

Is this issue happening on sites hosted by FlyWheel?

Are you running the latest versions of DMS ?
Does the issue persist when you disable all active plugins ?

 

Can you provide links to all sites having the issues, along with providing the host of the site and make sure debug mode is active please on all sites.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dario

I'm running into this issue as well, on both of my local development sites.

 

WP 4.

DMS (2.1.8).

Child theme: RCS.

PHP 5.6.2.

All plugins are deactivated.

 

Mac OSX 10.9.5

Chrome 38.0.2125.111

MAMP PRO 3.0.7.2

 

Debug dump (showing active plugins, though the CSS issues happen when all are deactivated and completely off the site):
DMS Debug Info

WordPress Version
4.0

WordPress Debug
Disabled

Multisite Enabled
No

Current Role
Administrator

Framework Path
/Users/Test/Sites/rcs/wp-content/themes/dms/dms

Framework URI
http://rcs:8888/wp-content/themes/dms/dms

Framework Version
2.1.8

PHP Version
5.6

Child theme
Yes

/Users/Test/Sites/rcs/wp-content/themes/rcs
http://rcs:8888/wp-content/themes/rcs

WP_DEBUG
No

WP memory limit
40 MB

WP MAX memory limit
256 MB

PHP memory limit
256 MB

Mysql version
5.5.38

WP Max Upload Size
32 MB

PHP POST Max Size
32 MB

PHP Max Execution Time
30s

PHP type
Apache2handler

WebServer software
Apache

PHP User
_www

OS
Darwin

Installed Plugins
dms-dev-tools/dms-dev-tools.php
dms-plugin-pro/dms-plugin-pro.php
footer-extras-dms/footer-extras-dms.php
groups-woocommerce/groups-woocommerce.php
groups/groups.php
pagelines-customize/pagelines-customize.php
pagelines-updater/pagelines-updater.php
sensei-certificates/woothemes-sensei-certificates.php
sensei-media-attachments/sensei-media-attachments.php
sensei-modules/sensei-modules.php
simple-drop-cap/simple-drop-cap.php
ubermenu-megamenu-adapter/ubermenu-megamenu-adapter.php
ubermenu/ubermenu.php
woocommerce-anti-fraud/woocommerce-anti-fraud.php
woocommerce-cart-notices/woocommerce-cart-notices.php
woocommerce-dynamic-pricing/woocommerce-dynamic-pricing.php
woocommerce-follow-up-emails/woocommerce-follow-up-emails.php
woocommerce-gateway-amazon-payments-advanced/amazon-payments-advanced.php
woocommerce-gateway-stripe/woocommerce-gateway-stripe.php
woocommerce-pdf-invoice/woocommerce-pdf-invoice.php
woocommerce-product-bundles/woocommerce-product-bundles.php
woocommerce-subscriptions/woocommerce-subscriptions.php
woocommerce/woocommerce.php
woothemes-sensei/woothemes-sensei.php
woothemes-updater/woothemes-updater.php

Share this post


Link to post
Share on other sites
dario

I do wonder, however, whether my process is sound.

Should I be adding my custom CSS via the DMS editor (</> Custom), or am I better off doing it directly on the style.css file (using Coda2)?

Share this post


Link to post
Share on other sites
Guest

2.1.8 fixed these issues for me.  @dario:  I use the DMS editor for all my custom CSS.

Share this post


Link to post
Share on other sites
Danny

rlogan - Thanks for letting us know, we appreciate it.

 

dario - The Custom panel in DMS should be used really for small simple snippets, if you want to use advanced CSS or LESS such as variables, mixins etc.. then you should really use a code editor to make sure your code is sound i.e. via a lint package and then paste this into the style.css or style.less file in your child theme. Not a big fan of Coda2, to me there is too much bloat, you should give Atom.io as try, its awesome.

 

In regards to your issue, i.e. CSS not saving, the only way this could happen from my experience is:

 

1. You have a LESS Parse Error caused by invalid CSS/LESS

2. Your server has a weird configuration

3. You have cache enabled in either a plugin or something like CloudFlare.

 

I have added hundreds of lines of LESS to my local test sites child theme via the style.less file and some in the Custom panel and I have never experienced my CSS/LESS not saving.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dario

Thanks Danny.

It must be something on my server setup then. I have noticed that MAMP is painfully slow as well.

Doing tests with some host file and php adjustments to see if that resolves things.

 

Never heard of Atom but I'll check it out.

Share this post


Link to post
Share on other sites
dario
Here is the solution which worked for me. Perhaps it might help another.
FWIW, no LESS errors and no Cache plugins or CDNs on my setup.
All on a Mac, Mavericks, MAMP PRO local server. Latest versions of each.
I've yet to confirm that just one of the following works for me, on its own, so I went for the shotgun approach.
  • In MAMP, don't name your dev site(s) localhost nor append .localhost to it.
  • Stop all servers
  • Add the dev domains to the search domains in System Preferences / Network / Advanced / DNS.
  • Add the dev domains to your hosts file (/private/etc/hosts), like the following. Everything in blue was already present or added automatically by MAMP after my adjustments. Don't forget to tab between host entries, not just a space ( denoted below as (tab) ):
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost (tab) devsite (tab) devsite1
fe80::1%lo0 localhost
127.0.0.1 devsite (tab) devsite1
fe80::1%lo0 devsite (tab) devsite1
127.0.0.1 devsite # MAMP PRO - Do NOT remove this entry!
127.0.0.1 devsite1 # MAMP PRO - Do NOT remove this entry!

Save the file.
  • Open the PHP ini file for the PHP version you're going to use (/Applications/MAMP/bin/php/phpx.x.x/conf/php.ini) (x.x.x =latest PHP version) and near the bottom of the code you will see the following:
[OPcache]zend_extension="/Applications/MAMP/bin/php/phpx.x.x/lib/php/extensions/no-debug-non-zts-20121212/opcache.so"opcache.memory_consumption=128opcache.interned_strings_buffer=8opcache.max_accelerated_files=4000opcache.revalidate_freq=60opcache.fast_shutdown=1opcache.enable_cli=1
After the last line, add: enable=0 (or comment out the entire section by adding ; to the beginning of each line)
Save the file.
  • Back in MAMP PRO, click on the PHP tab and make sure that the setting for 'Cache module to speed up PHP execution' is set to off. Adding enable=0 to the PHP.ini file was probably redundant, given this MAMP PRO setting, but I had to do it anyway.
  • Restart servers.

Share this post


Link to post
Share on other sites
Danny

Thanks for sharing.

 

Here is a link to the Atom editor, which is developed by GitHub themselves - https://atom.io/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×