Jump to content

Archived

This topic is now archived and is closed to further replies.

bigtopmultimedia

Problem with header being duplicated on the page

Recommended Posts

bigtopmultimedia

I have a problem with this site: http://dev.familyfun.ie/, where the header is being repeated on the page. The 2 headers have exactly the same ID, so deleting the content from one also deletes it from the other. The header shows up twice in edit mode as well.

 

I added a test string inside the <header> element in the header.php file and that text only shows up in one of the headers, as can be seen on the page.

 

What is causing this and how can I remove the duplicate?

Share this post


Link to post
Share on other sites
bigtopmultimedia

I should say that this happened when upgrading from v 2.0.7 to 2.1.8

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You're going to need to enabled DMS debug mode and also, disable all active plugins and remove all custom scripts and CSS/LESS CSS you my have added. As the likely cause of this is a conflict from one of them.

Also, I suggest you revert the header.php file back to its default, as we can not provide support to users who have made changes to the core files.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
bigtopmultimedia

Thanks for the reply Danny. The site is using a child theme. After some testing it seems that the issue is caused by the presence of a header.php file in the child-theme folder - even when it's an exact duplicate of the DMS file. Is this expected? I admit I haven't yet disabled all the plugins, so if you tell me that it's not expected I'll do that and test further.

Share this post


Link to post
Share on other sites
Danny

Yeah there is no need to have header.php in your child theme, just remove it.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×