Jump to content

Archived

This topic is now archived and is closed to further replies.

bartoncollege

Listing posts by category

Recommended Posts

bartoncollege

I'm having difficulty getting a list of posts on a landing page.  I would like to achieve something like the Posts widget, but I need to be able to specify categories, include excerpts, and display the post dates.  I've tried using the Column section and adding the [display-posts] shortcode, but this shortcode doesn't get processed.  Only the shortcode text shows up.  Am I missing something?

 

Thanks.

Share this post


Link to post
Share on other sites
bartoncollege

Thanks for the tip!  Also, I must admit that I experienced a small amount of excitement when I looked in my inbox and saw that I had a message from Batman. :-)

Share this post


Link to post
Share on other sites
batman

bartoncollege

"a small amount of excitement"

:D

 

Thank you for the "Best Answer"

Regards

Carlos

 


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites

  • Similar Content

    • jeomiland
      By jeomiland+
      Howdi
      Am following a couple of tutorials about making custom shortcodes and making them available in your site. They recommend to make a "my_custom_shortcode.php" file in wp-content folder so it survives Core wordpress and Theme updates. However, they then say to place a couple lines of code in the theme functions.php file. The one in pl-framework theme folder does not look like the best place to put that code and I can't see a shortcodes.php file in the theme.
      So where is the best place and way to add custom shortcodes to a Pl5 project?
      Thanks
      john erik
    • jeomiland
      By jeomiland+
      Hi
      Have researched this in the forum and find a couple ancient posts from 2011 and 2014 apparently for pre-DMS2?
      Am using latest Wordpress  4.8.4 running DMS Version: 2.2.4 theme
      When in the editor (Chrome), the page looks fine, but when logged out and viewing individual posts, they show up twice - one in the column I have setup and a second time at bottom of content page but above footer???
      Each page has 2 columns, left column is biggest and contains wploop/content and comments. wpcontent loop is displaying a second time below both columns but ONLY when not in editor. While in editor, second wp content block does not appear???
      https://cassclayton.com/el-chapultapec/  is a post. You can get to it from NEWS | News/Blog dropdown menu, then choosing a post.
      The 2011, 2014 posts talk about going into Settings and adjusting the excerpts vs full settings, but can't find anywhere to do this in DMS???
      Not sure if this is a new issue or old one i just now noticed.

      Best regards,
      John-eriK
       
    • Jason
      By Jason+
      Any chance you can add anchors to the tabs shortcode (similar to ultimate shortcode plugin)?
      Just annoying having to use that plugin rather than pagelines one
       
      <h2>Tabs anchors</h2> [su_tabs] [su_tab title="Tab 1" anchor="First"] Tab 1 content [/su_tab] [su_tab title="Tab 2" anchor="Second"] Tab 2 content [/su_tab] [su_tab title="Tab 3" anchor="Third"] Tab 3 content [/su_tab] [/su_tabs] Use next links to switch this tabs <a href="#First">Open tab 1</a> | <a href="#Second">Open tab 2</a> | <a href="#Third">Open tab 3</a>  
    • Jason
      By Jason+
      Any solution to map section not rendering inside tab shortcode.
      (Map sits inside 3rd tab so map not visible on page load)
      Also this just seems to effect the map section. Map shortcode renders fine.
      I want to use the map section for finer control over markers and locations
      Renders fine if in first page.
       
      Thanks
    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
×