Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

Excerpts

Recommended Posts

sheilahoff

This site is running DMS 1.1.8. On the blog page we want to have the normal excerpts with thumbnail arrangement. We have List Layout Mode selected and have NOT checked to hide excerpts. We have continued reading link set to Read More... and a number of words set to 250. Metabar Mode is also selected. With these settings we see all full posts unless we add a Read More tag in the post itself which then works fine. (first 2 are done that way) What are we doing wrong?

 

http://coachmediateconsult.com/ask-karen/


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

HI,

 

As far as I can tell that isn't just the DMS 1.x PostLoop section you have something else working alongside from the looks of it. As you have a lot of elements using something called bd ?

What is bd ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Interesting. I have NO idea. I just poked around a bit. The live site has a DMS Base Child theme v 1.0.2 installed along with DMS 1.1.8. On my cloned version I switched it from the child theme but still see the bd class throughout. I just have NO idea what that's from. The only plug-ins I have installed that start with a B are Backup Buddy and Business Branding. Other PL plugins include ProTools, CrackBar, Classy, Selettore Tabs, PL Google Fonts. I do have a plug-in called Hide Categories installed.

 

So then I went into the cloned site and disabled ALL plug-ins. Even with everything turned off I still see the bd class. I don't know what it is BUT I don't think it's the problem either. You can see the cloned site with all plug-ins disabled here: http://cms.wpstagecoach.com/ask-karen/

 

As you can see in this capture of the live site the DMS looks prefectly normal as does the section. I haven't done anything unusual to it:

http://awesomescreenshot.com/00e3opsq1a

 

Any any ideas? I'd be happy to create a login for you.

Thanks.

 

PS: I just checked and my other DMS1 sites all have the bd class. So it's definitely something else.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
sheilahoff

I still haven't resolved this but I'm also needing input on how the featured thumbnail choices work. If I choose On Top in Full Width Thumbnail Layout I get the large image across the top in both the excerpt and the full post. Left justified puts it into the title so then I choose Left in Excerpt. This adds it as desired in the full post with the text wrapping around it but in the excerpt it doesn't wrap and looks terrible as shown here: http://awesomescreenshot.com/0f23oxut89

 

WHY doesn't it wrap in the excerpt listing? And is there any way to have the thumbnail on the excerpts (wrapping of course) AND to have a full width version of the image on the full page post?

 

Thanks,

Sheila


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
sheilahoff

Update: I went ahead and tried updating the cloned site from DMS 1 to 2. The elements using BD are still there both with and w/o the plug-ins enabled. The "good news" is that with DMS 2 the excerpts work as expected. The bad news is, of course, I would have to completely rebuild the site to upgrade. PITA. Not getting paid for that so won't do it.

 

I hope someone can help with making excerpts work as they should in DMS 1.

 

Thanks.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Can you disable all active plugins and then provide screenshots of your postloop settings please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

OK, I currently do not have a zip or test site running DMS 1.8, need to speak to our devs to get one. What happens if you remove the Read more text and remove the 250 value from the excerpt length option, do your posts display correctly ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

I just tried that with the same result. I made sure I'd emptied the built in cache as well.

 

I'd be happy to provide a temp login to this site since it's a clone and not live. Let me know where to email it if you'd like.

 

BTW...I also removed ALL CSS and still not getting the thumbnails to wrap or excerpts w/o read more tag.

 

PS: Just pm'd credentials


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

As far as I can tell, there is something wrong with your sites setup and I am not sure what. As I have just this moment added DMS 1.8 to my site and used the following settings:

 

https://cloudup.com/cUYlfx2Xteq

 

My excerpts are working as intended - https://cloudup.com/cm3W9HTY_s8

 

Also, you're using Show full post content and have hide excerpt set ? You also have no excerpt length setting, you're using the default.

Also, the DMS toolbar icons are not appearing, therefore there is certainly something wrong with your configuration. There is no errors, the only thing there is two things from your debug info.

 

PHP Open basedir restriction
Yes!
/var/www/cmc
 
PHP User
Posix functions are disabled on this host!
 
I recommend you contact the host and ask them to resolve these issues. In regards to the loop issue, there is no issue, it has to be something on your server that is causing the issue. As I am unable to recreate it on a vanilla DMS installation.

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Danny, thanks for continuing to try to assist.

 

First of all my settings are the same as yours. I removed the Read more and 250 per your request and didn't put it back, but it had been there and works the same with and w/o it. I just added it back in the clone side. Second of all, my live site is on one server and my cloned site on another. I have the same issue on both. I'm not sure that debug info you uncovered is even present on the live server. I have turned on debug there. I don't know how to use it but perhaps you can confirm if those same issues appear at http://coachmediateconsult.com/ask-karen/. If you think they are the issue I will see about my server settings. But ALL my DMS sites are on this server and the rest all function correctly including my DMS 1 sites.

 

I had not noticed the missing icons on DMS until now. I think that may've just happened. I have NO idea why. But I do see that it is an issue on both the live and cloned version. I tried removing the custom font code in the header which didn't fix it. What could be causing that? Would reinstalling DMS help perhaps?

 

You said "you're using Show full post content and have hide excerpt set"...but I don't think so. Where? I have nothing checked at all. I do hope we can figure this mess out!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

As I mentioned above, you're using show full post content and have hide excerpts set, disable both options, will resolve your issue.

 

My options for Show full post content and Hide excerpts look like this:

 

 

https://cloudup.com/cK4o7h2kfOk

https://cloudup.com/cJNB_InwBsB

 

Yours however, look like this:

 

https://cloudup.com/ck04ytXOl8O

https://cloudup.com/cZBCXTABc6D

 

So you actually have Show Full Post Content and Hide Excerpt active, disable them and the PostLoop will work as intended.

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Thanks Danny. I think I have it now. I'm sure I've tried that before but for some reason the toggling back and forth was never the right combo. Those boxes are far from intuitive. I'm pretty sure it's working correctly now. THANK YOU!

 

I think part of the issue is that she wanted her posts in the category Words of Art to be full posts and not excerpts but we wanted the rest of the posts to be excerpts. I'm assuming there's no way to have this managed by category?!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

If this is a specific category, then no there currently isn't a way unfortunately. If your client wanted to display full posts content on all categories, you could try creating a template for categories and changing the Loop options. However, if this is for one particular category, then there currently isn't a way.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

thanks Danny...that's what I thought. Case closed.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • mundocaco
      By mundocaco+
      Hello, inexplicably few signs have appeared at the beginning of each excerpts, removing the option these signs disappear, but appear when I activate it again. You know why happen this?.
       
      Yo can see online here: http://www.latitudestudio.eu/press-news/ 
       
       
    • dherries
      By dherries
      I am trying to add a widgetizer to my page/post and the system does not let it drag. The system creates  large Widgetizer logo and nothing will happen. What am I doing wrong?  I am using DSM 1.1.9.  Website is www.moveincache.com
    • mundocaco
      By mundocaco+
      Hello everyone. :)   Is possible set a selected Section Area to height of window browser with custom CSS, just like DMS2 presets? Someone knows some best practice?   I know how to set to fixed footer, but i think this case of study is different.   Thanks!
    • webmktco
      By webmktco
      Website URL: http://www.schrumpfdds.com/
      Framework Version: DMS 1.1.9
      WordPress Version: 4.1.1
       
      I noticed that the Font Awesome version in my theme is 3.2.1.
       
      Can you tell me how I can update the FA version? Or is that not possible?
    • pazyluz
      By pazyluz+
      I have pages that display on phones and pages for desktops/laptops.  The ipad displays the mobile/phone pages but would look far better if they displayed the desktop version.  How/Can I display the desktop version on ipad?  If I cannot do that, can you advise me as to the best course of action?  Thank you.
       
      http://peggygreen.net
×