Jump to content


This topic is now archived and is closed to further replies.


QuickSlider tuning

Recommended Posts


Hi everyone!


I use quickslider section for galleries.

Could someone advice me css modifications for quickslider navigation?


Now user can navigate only using black arrows left/right on the left top of the image. 

(see example http://a.autom.com.ua/aston-martin/ http://a.autom.com.ua/audi/)


This looks very goods, but the usability of this solution is too low.


How can I change these arrows to something else? 

Can I use arrows on the middle of the image edges (one on the left, one on the right) etc? 


thank you 


Share this post

Link to post
Share on other sites



You will need to use custom CSS to reposition them. If you use the following you code:


#site ul.flex-direction-nav {
top: 50%;
#site .flex-gallery ul.flex-direction-nav a {
width: 100px;
height: 100px;
font-size: 100px;
line-height: 50px;
#site ul.flex-direction-nav {
top: 50%;
width: 100%;
#site .flex-gallery ul.flex-direction-nav li:last-child {
float: right;
margin-right: 8px;
and will look something like this - https://cloudup.com/cO9Qup6kpHd


Additional CSS may be required and this kind of customization isn't something we can provide support for, so you will need to fine tune it yourself.


In regards to changing the icons, you will need to create a child section via a child theme and make your changes to the section.php file inside your QuickSlider child.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

Hi Danny, 


thanks a lot for the solution, it looks great.


the only trouble I have is the arrow positioning inside of the square. 


it looks more or less good in safari ( http://a.autom.com.ua/test/safari.jpg), but not so good in chrome/firefox: ( http://a.autom.com.ua/test/chrome.jpg )

how can I center the arrow in the square? 


thank you in advance



Share this post

Link to post
Share on other sites

You will need to play with the CSS, the CSS I gave you was just a quick draft. We do not actually provide support for customization like this.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

@Danny, sorry for reviving this old post, but I'm having problems to change the arrows on a site. They are displayed on the top left by default. I actually want them to be bottom right. So far I managed to put them bottom left, not right. This is what I tried:


#site ul.flex-direction-nav {
top: 70%;
float: right;

somehow the float line isn't working. The 'right' stays in black colour instead of green.

Share this post

Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?