Jump to content

Archived

This topic is now archived and is closed to further replies.

m110033

how to set the icon's background of the iHeader by custom css?

Recommended Posts

m110033
Hi everyone, how to modify the background-color inside the icon of the iHeader? Here is the result what I had done, http://imgur.com/bgYWLyk, but no matter how I set the css for it, it always shows the black background there. Inside the red rectangle, it has a little black background but I need to set it to green. here I show what I had tried below. thanks everyone.
 
div.nav-wrap.fix.classic {
  opacity: 1.0;
  background-color: #90C42F;
  color: #ffffff;
  
  ul.homebutton, li a {
    opacity: 1.0;
    background-color: #90C42F;
  }
  
  & a:hover {
opacity: 1.0;
  background-color: #ff0000;
    .border-radius(4px 4px 4px 4px);
  }
}

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You will want to use something like this:

 

.homebutton li {
background: #F00;
}
 
For hover state use the following:
 
#site .homebutton > li:hover {
background: #008000;
background-color: #008000;
background-image: none;
box-shadow: none;
}

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
m110033

Dear Danny,

 

I got the main point for setting it is the "box-shadow: none;"  Thank you.  =) 

Share this post


Link to post
Share on other sites
Danny

No problem, happy to help!


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Dan Haddock
      By Dan Haddock
      Hi Pagelines team and wider community,
      I am looking to develop a single post page for my blog. I have read over an old article on the subject, however the link provided on achieving this goal was giving me security warnings. Is there any way I can get round this?
      Secondly, I have had a root around the .zip file provided on my sites backup, however was unable to locate any file in there with the name of Single.php. Does this file exist in the Pagelines theme?
      By the way, this is the unsafe article: http://support.pagelines.me/docs/customization/create-a-custom-page-template/ (Click at your peril).
       
    • mzhafzah
      By mzhafzah
      Hello
      I am using DMS 2 theme and I want to create a 2 different links on my website; each link should take you to a different blog post category. Although the process is easy, yet I can not figure out how to give each category page a unique design of its own; Any change I make on any page is applied to the other (I'm aware of the universal elements like the header and footer and I a am not talking about these.)
      Since I am new to wordpress in general, I am not sure if my description is sufficient; apologies if it is not.
      TycoonJé
    • napait
      By napait+
      Hello All,
       
      My question is.. How do I add more social icons using the Navi section in Mobile Menu mode?
       
      The only two that show up are the Facebook and Twitter, from the information you fill out in the Site Setting > Social & Local.
       
      Please review site for example: www.napait.com
       
      I would like to be able to add custom icons such as other social and phone, map, contact icons after these social icons in the mobile menu. Basically want to move the phone icon into the social icons bar. Having looked for the right hook using Hooker plugin I still have been unsuccessful.
       
      Thank you in advance.
       
      Kevin
    • tristanrodgers
      By tristanrodgers
      Website URL: http://mc1r-magazine.com/
      Framework Version:  2.1.9.2
      WordPress Version: 4.1
      Plugins in Use: The Pagelines Plugins
       
      Hey guys,
       
      I have a problem since I tried to add a custom font in my theme.
      I created a font-face-kit via "font-squirrel" and I tried to include the font on this way the docs tell me to do it:
       
      http://docs.pagelines.com/tutorials/adding-custom-fonts
      http://docs.pagelines.com/customize/base-child-theme
       
      But it didn't work and it messed up the page in Firefox. Of course the Cache is empty, code deleted, plugins deactivated, but it still shows a messed up page in Firefox! I've included 2 screenshots to show you the problem (and another problem with the background-color of the font, maybe you see there is blue but I've chosen an orange)
       
      Greetings,
      Tristan
×