Jump to content

Archived

This topic is now archived and is closed to further replies.

jennajonesdesign

Mobile Help!

Recommended Posts

jennajonesdesign

Hi Guys!

 

I made this site for a client: http://www.rondakiesser.com/

 

She loves it on a desktop, but mobile isn't looking great. I need to figure out how to do a few things. 

 

1.) Scale the background image for mobile. I would like the whole photo to display on mobile. 

2.) Hide buttons for mobile view

3.) Scale logo for mobile

 

Here is the inspiration site we were looking at: http://mrslusko.com/

 

Even if I could just get the background image to scale like the link above we would be happy. Thanks!

 

Jenna

Share this post


Link to post
Share on other sites
Danny

HI Jenna,

 

To do this you're going to need to use media queries and target those element individually with additional CSS. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jennajonesdesign

Hi Danny, 

 

I think this could all be solved with just using the Pro Plugin with turning sections on and off for mobile. I do have that plugin installed and I do not have those check boxes available. I just checked documentation and I don't think I am doing anything wrong. Is there something I need to do to enable the hidden sections feature with the check boxes??

 

Jenna

Share this post


Link to post
Share on other sites
Danny

Hi Jenna,

 

You need to check the Allow Hidden Sections in DMS Pro Tools, if that remains unchecked, the options will not appear.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jennajonesdesign

Ah! Finally found it! I was looking everywhere on the front it. It is confusing that the Developer tool options are on the front end and the Pro tool options are on the back end. Not intuitive! Thanks so much. Love this feature. Solves most mobile problems for my sites.

 

Jenna

Share this post


Link to post
Share on other sites
Danny

The DMS Pro Tools can not be on the front end as the whole purpose of the DMS Pro Tools is to add additional functionality to DMS as we can not include due to the free version on WP.org. The developer tools plugin can be on the front end as it is only adds simple functions/features. However, I will make this easier on our new upcoming documentation.

 

However, the DMS Pro Tools plugin has existed since almost the launch of DMS itself and has never changed position. Does that mean you have had this plugin installed for over a year and never knew what it did or where the options were ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jennajonesdesign

Yes @Danny! I have been installing it for over a year and did not know which features or where anything was being added! It is literally the only feature on the back end and I was just so used to everything DMS being located on the front end. So glad you told me. Hard lessons are not forgotten, so I will for sure remember for the future! Thanks!

 

One other note. Since there have been so many changes, I didn't realize until recently that I should be installing the theme with both Pro and Developer tools. I was assuming if I installed the developer version of the theme that I downloaded from my paid account that it would have the extra features built in. I am remembering there is the little note that tells you to install one of them - but not both right? 

 

It just hasn't been clear to me until recently that I do need to use both and that they offer separate features. 

 

Not mad! Just feedback from someone who builds ALOT of DMS sites. =)

 

Jenna

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×