Jump to content

Archived

This topic is now archived and is closed to further replies.

vanessabt

disable sections on mobile viewing

Recommended Posts

vanessabt

Hi, 

I saw the sections in the dms manual for browser specific viewing.  I need to turn off one slide in my slider on my site because it does not show the video background when viewed on phones.

 

here is the site http://rugammasigma.com/.  the slide with the house with the fire behind it does not show the fire on a phone.  Can I turn off just one slide when it is viewed on mobile?  If not, I would like to build an alternate page header using the page headers section that is only viewed on a mobile device but not on any other devices or computers. 

 

Please advise on what can be done.

 

Share this post


Link to post
Share on other sites
jennajonesdesign

Oh! I would also be interested to know if video backgrounds never display on mobile. That is kind of a big deal. I am working on a site like that now. I know Revolution Slider does have the option for an alternate backdrop, but I was planning on using the default DMS features. 

 

Jenna

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The video not displaying on mobile phones, I believe is indeed a bug, which is something our developers are looking into. However, if you wish to hide specific sections on mobile devices, you will want to enable the option in the DMS Pro Tools plugin. Once enabled, all sections will have additional settings where you can hide sections on desktop or mobile devices with a check of a box.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vanessabt

okay. great. I will activate that plugin.  Can you please let me know when the problem is resolved because I would really like to use the slide on mobile devices as well.

 

thanks.

Share this post


Link to post
Share on other sites
vanessabt

"Once enabled, all sections will have additional settings where you can hide sections on desktop or mobile devices with a check of a box."

 

It is enabled but I do not see any checkboxes in the revslider section that would allow me to disable this or any other section.  Please advise.

Share this post


Link to post
Share on other sites
jennajonesdesign

Danny so glad you said that about the plugin! I thought for sure I had seen that feature, but was wondering if I was crazy or remembering it from a different theme. Thanks!

 

Share this post


Link to post
Share on other sites
Danny

vanessabt

 

The RevSlider like all other sections have these options - https://cloudup.com/chbBcItiF9a

If you're not see them you're likely running an out of date version of DMS and/or DMS Pro Tools plugin.

 

jennajonesdesign - No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kboyle10

If we have a skin applied from the PageLines store... do we lose these options? I'm showing I'm up to date , but I don't see these options either.

Share this post


Link to post
Share on other sites
Simon

If we have a skin applied from the PageLines store... do we lose these options? I'm showing I'm up to date , but I don't see these options either.

Those options are provided by the pro tools plugin.

Share this post


Link to post
Share on other sites
kboyle10

Simon_P ... yeah. Thats the same as DMS Professional Tools right?

 

I have that plugin, but still don't see these options.

Share this post


Link to post
Share on other sites
Simon

Did you enable the option in the tools settings?

Share this post


Link to post
Share on other sites
kboyle10

Well dang. What do you know that did it! :P  Thanks!

 

I did find a work around as well. If you create a blank .png background... set that for the slide. Then set the video for slide as well, the video still shows. Then outside the slide, set the background image and that's what will show on a mobile device.

Share this post


Link to post
Share on other sites
vanessabt

I don't know. My plugins are up to date and I still don't see those options anywhere in the pagelines section options or the tools section in DMS2 that Danny has a screen shot of.

 

I set the background outside of the slides to black so now that will show up on mobile for a second but the video component still does not show up on my mobile.  In addition, the load of the sliders is very choppy and I get this error on loading mobile "a problem occurred with this webpage so it was reloaded" and eventually it stops trying to load and says that there is a repeated load error.

 

I currently have the video playing in the general background of the whole slide, should i set that for an individual slide instead?  There was a reason I set the video outside of the slide but it has been a while that I have had this issue so I am don't recall at the moment.  If someone could look at my site that would be really helpful and let me know what I need to do.

 

Please advise.

Share this post


Link to post
Share on other sites
kboyle10

The video won't ever show up on mobile because video can't autoplay on mobile and with the background option, there is no play button. So for mobile you need an alternate background image. 

 

The alternate solution I gave above will show the image on an ipad and on a iphone, it will just take the entire section away. To me that seems to be the best option until mobile phones autoplay video.

Share this post


Link to post
Share on other sites
vanessabt

i don't think that work around does the trick for me because my slide has an image that actually lays on top of the video component.  I think that is why I had to set the video for the main background option to begin with... I believe I had tried to set the video in the slide with the image but then it only showed the video?....

 

I will have to run some more tests on it as well.  If I can lay image into the slide with the video and they both work I could then put the alternate image in the background outside the slide.  I guess I will see tomorrow.  thanks for your help. I will keep you posted.

Share this post


Link to post
Share on other sites
kboyle10

Yeah, just make sure the image for the slide is just a transparent png file. I don't know if size matters but I just followed the size recommendation given.

Share this post


Link to post
Share on other sites
vanessabt

what if I put something like this is in the custome css areas and reference in the css style for the section?  has anyone tried this?

//medium+ screen sizes
@media (min-width:992px) {
    .desktop-only {
        display:block !important;
    }
}
 
//small screen sizes
@media (max-width: 991px) {
    .mobile-only {
        display:block !important;
    }
 
    .desktop-only {
        display:none !important;
    }
}
 

 

Share this post


Link to post
Share on other sites
Danny

You shouldn't need to use custom CSS, when the options are already there for you via the DMS Pro Tools plugin. If you're not seeing these options, please provide a link to the site in question and screenshots of your DMS Pro Tools options page.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×