Jump to content

Archived

This topic is now archived and is closed to further replies.

John Olsson

Container outside navbar

Recommended Posts

John Olsson

Hi folks!

 

Been trying to fix a thing, it's completly css, but maybe there's someone whos done it.

 

I have my fixed navbar, no problems there, But I want som graphics, css, och whatever to go outside the navbar container, for example..

 

How can i accomplish to have <img src="navbar-bg.png"> to go outside below the logo as in the image, yes, an ugly example, but u get the point! :)

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Unfortunately, this isn't something PageLines staff can assist you with as it is user created code. However, one of our users may be able to assist. The simplest method would be for you to create a child of the section via a child theme and then add your image to the section.php file.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
John Olsson

Ah, I see.. thought that someone maybe had a good css-fix for this! :) I'll keep on trying and i'll post it if I solve ut!

Share this post


Link to post
Share on other sites
Danny

OK, so I was playing about and come up with this, you will likely require additional CSS and what I provide below is very rough.

 

#site .plbrand img {
position: absolute;
z-index: 999;
max-width: 100px;
top: 0;
left: 0;
}
 
This gives me logo the following look - https://cloudup.com/co_HnS8Fm0P

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
John Olsson

Appreciate that, however, i was looking for a fix for the static navbar that scrolls down along with the page, or should it work either way maybe?

Share this post


Link to post
Share on other sites
Danny

Not sure what you mean by static NavBar, the code targets the NavBars logo image, so it will work for all NavBars. However, you will likely need to use additional CSS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
John Olsson

Ah, ok, get it.. so I made just a very quick css, but changed the target doh..

 

But it works, just for other users so they can use it and customize it!

 

.section-navi img {
  position: absolute;
  z-index: 999;
  max-width: 100px;
  top: 10px;
  left: 0px;
  background: #000;
  border-radius: 10px;
  padding: 10px 20px;
}
 
 
..and it works fine when scrolling down the page as well..

Share this post


Link to post
Share on other sites
Danny

Thanks for sharing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×