Jump to content


This topic is now archived and is closed to further replies.

Keith Vaugh

Selecting the correct menu on a multi language site - polylang

Recommended Posts

Keith Vaugh

Hi all


Can't figure out how to get the correct menu to appear when navigating on a sites second language. It working fine for the english version but when I browse to the german version of the site, the menu does not update. All pages have been cloned and text localised to the region concerned. Also because the english menu remains the active one, when you follow a link to goes back to the english site. 

I have two menus define MAIN (english) and MAIN_de (German) and am using polylang plugin.

the url is http://www.etterhorses.com/etter2014


Any assistance would be most welcome. 

Thanks in advance. 

Share this post

Link to post
Share on other sites
Keith Vaugh

In case anyone else is having trouble with this in the future, ensure that the select menu of the navigation is set to default. In my case I had it defined which was cause the multi language to be over-written. It was an easy fix in the end.

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?