Jump to content

Archived

This topic is now archived and is closed to further replies.

swiftitnz

Add lightbox effect to manually added images

Recommended Posts

swiftitnz

Hello people, I have been working on this site: http://mostrespectedagents.net/ and added few images for agent profiles manually.

 

I was looking to use a plugin to get the lightbox functionality for thumbs > bigger images. Therefore, I installed 'Simple Lightbox' but it didn't work. Which is most likely because of clashing with DMS. Is it correct?

 

Hence, I have used html/css (I have pasted below) and got the result but with a huge issue. If you kindly notice at the bottom of the site, there is a huge white space right below the footer/copyright module.

 

Any suggestion on how to achieve the desired result without either of the issues?

 

Any help is appreciated.

 

Regards,

 

Imran

 

HTML:

<a class="thumbnail" href="#thumb"><img src="http://mostrespectedagents.net/wp-content/uploads/2014/09/TW-Optimus-Team-Photo-Tenga-Helen.jpg" width="200px" align="left"><span><img src="http://mostrespectedagents.net/wp-content/uploads/2014/09/TW-Optimus-Team-Photo-Tenga-Helen.jpg" /></span></a><span style="font-size: 150%; font-weight: bold;">Tenga Schieber<br>Team Realty of Atlanta</span><br><br><span style="font-size: 110%; font-weight: bold;"><a href="http://www.teamrealtyofatlanta.com">www.teamrealtyofatlanta.com</a></span>

CSS: 

.thumbnail{
position: relative;
z-index: 0;
}

.thumbnail:hover{
background-color: transparent;
z-index: 5;
}

.thumbnail span{ /*CSS for enlarged image*/
position: absolute;
background-color: black;
padding: 1px;
left: -700px;  
border: 1px dashed gray;
visibility: hidden;
color: black;
text-decoration: none;
}

.thumbnail span img{ /*CSS for enlarged image*/
border-width: 0;
padding: 1px;
  
}

.thumbnail:hover span{ /*CSS for enlarged image on hover*/
visibility: visible;
  top: 0;
right: 0;
 /*position where enlarged image should offset horizontally */

}


Share this post


Link to post
Share on other sites
Danny

Hi,

 

I am not seeing any issue in regards to space at the bottom of your site, has this been resolved ?

 

Also, if you only have space after using the plugin/HTML, then the issue is with the plugin or you code. Which isn't something we can assist you with.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Kedark
      By Kedark+
      Hello,
      I apologize for the trivial question, but I can not deal with it. How do I turn off the display of a distinctive image on the page? (I have to add it because I use plugins that use it), but as I display the page, I do not want it to be visible (and appears above the subject.).
      Probably a cliché but I can not deal with it. Therefore, a request for help.
      Regards
      RKA
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • mtaus
      By mtaus+
      I have added a Lax section on the footer of this site: http://www.ics-law.org.php72-38.lan3-1.websitetestlink.com/ but the background image is not displaying. When I first add the image it appears in the background, but then after saving and reloading it is gone even though the thumbnail indicates it's still there. Screenshot attached.
      Any suggestions?

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
×