Jump to content

Archived

This topic is now archived and is closed to further replies.

swiftitnz

Add lightbox effect to manually added images

Recommended Posts

swiftitnz

Hello people, I have been working on this site: http://mostrespectedagents.net/ and added few images for agent profiles manually.

 

I was looking to use a plugin to get the lightbox functionality for thumbs > bigger images. Therefore, I installed 'Simple Lightbox' but it didn't work. Which is most likely because of clashing with DMS. Is it correct?

 

Hence, I have used html/css (I have pasted below) and got the result but with a huge issue. If you kindly notice at the bottom of the site, there is a huge white space right below the footer/copyright module.

 

Any suggestion on how to achieve the desired result without either of the issues?

 

Any help is appreciated.

 

Regards,

 

Imran

 

HTML:

<a class="thumbnail" href="#thumb"><img src="http://mostrespectedagents.net/wp-content/uploads/2014/09/TW-Optimus-Team-Photo-Tenga-Helen.jpg" width="200px" align="left"><span><img src="http://mostrespectedagents.net/wp-content/uploads/2014/09/TW-Optimus-Team-Photo-Tenga-Helen.jpg" /></span></a><span style="font-size: 150%; font-weight: bold;">Tenga Schieber<br>Team Realty of Atlanta</span><br><br><span style="font-size: 110%; font-weight: bold;"><a href="http://www.teamrealtyofatlanta.com">www.teamrealtyofatlanta.com</a></span>

CSS: 

.thumbnail{
position: relative;
z-index: 0;
}

.thumbnail:hover{
background-color: transparent;
z-index: 5;
}

.thumbnail span{ /*CSS for enlarged image*/
position: absolute;
background-color: black;
padding: 1px;
left: -700px;  
border: 1px dashed gray;
visibility: hidden;
color: black;
text-decoration: none;
}

.thumbnail span img{ /*CSS for enlarged image*/
border-width: 0;
padding: 1px;
  
}

.thumbnail:hover span{ /*CSS for enlarged image on hover*/
visibility: visible;
  top: 0;
right: 0;
 /*position where enlarged image should offset horizontally */

}


Share this post


Link to post
Share on other sites
Danny

Hi,

 

I am not seeing any issue in regards to space at the bottom of your site, has this been resolved ?

 

Also, if you only have space after using the plugin/HTML, then the issue is with the plugin or you code. Which isn't something we can assist you with.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • mtaus
      By mtaus+
      I'm trying to add a Careers page to a site to display job openings. The plan is to create a Post using a subcategory 'Careers' and then display those on the page. All of the post sections in PL seem to include images and there's no obvious way to remove them or include an excerpt from the post. 
      Any suggestions?
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×