Jump to content

Archived

This topic is now archived and is closed to further replies.

margie

iBlogPro6 Navbar menu links don't work

Recommended Posts

margie

Hi-

 

Thanks so much for all your help thus far.  My company has decided to to go with the NavBar instead of the iHeader for navigation.  I went in to WordPress and unchecked the box as iHeader at the bottom of the menu for menu theme location.  Using the same menu I created for iHeader, I have 'Main Nav Section' and 'Mobile Navigation' checked at the bottom.  Additionally, I have my menu set for those locations under the 'Manage Menu' tab.  Problem is that nothing is clickable now when I view the website page.  That is to say, I click on the top menu item and nothing happens.  Same thing with the drop downs menu items.  Any help would be greatly appreciated.  So, my question s why doesn't the NavBar recognize my WordPress menu?  Or that's what it seems like.

 

Thanks so much.

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The NavBar section is based on Bootstraps navigation design. Where they have it so that parent items (menus that have child items) do not function as a link, but instead as an anchor. In which you click the parent item to access the drop down menu or child menu items. That is the reason as to why NavBar's parent items do not have links, if they did, you would access your drop down but then it load the page of the parent item.

 

So if you do not like this functionality, I would suggest replacing NavBar with Navi.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
margie

Thanks.  Switched to Navi-works great other than now my drop downs don't work unless your'e on the parent page.  Do I need to re-create my links to sections in the WP menu?  They were working before so when I click on the drop down menu item, I would be re-directed to the section associated with that menu item but now it only works if I'm on the parent page and then click the drop down item.

 

Thanks so much.  Have a great day.

Share this post


Link to post
Share on other sites
Danny

If you go to DMS Toolbar > Layout & Nav, there are options there that control how Navi drop downs works, you likely have the on click option enabled, change it to on hover.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×