Jump to content

Archived

This topic is now archived and is closed to further replies.

redstate

WP-Content Loop won't extend to full page

Recommended Posts

redstate
I'm trying to add a Piryx donation form to my Donate page with an iframe but the WP-Content Loop won't extend across the entire page. I need to change a setting somewhere but can't find it.
 
 
Piryx said the following but it doesn't make much sense to me since I don't know much code: 
 
"The issue is with other elements on the page and not the iframe. Please see below the changes you need to make to fix this:
 
"Currently the p tag is set to max-width of 560px which needs to be increased to may be 750px or more to see the full donation page":
 
.entry-title, .entry-content p {
  1. max-width: 560px;
}
 
 
.entry-title, .entry-content p {
  1. max-width: 800px;
}
 

What should I do?

Share this post


Link to post
Share on other sites
Aires

Hi redstate,

 

Can you give this a try

 

body .hentry iframe, body .hentry video, body .hentry object {
max-width: 850px;

 

~Aires


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
redstate

That worked. Thanks very much. I'd like to center the Piryx app better. How should I? I tried increasing 850px to 900px but that didn't work.

 

By the way, why did I have to enter that code? Why didn't the Piryx iframe code work in the first place, as it has on other WP sites I've produced?

Share this post


Link to post
Share on other sites
Danny

The iFrame isn't going 100% width of the container, because you have added this custom CSS:

 

.entry-title, .entry-content p {
max-width: 560px;
}
 
Which is setting anything inside a p class to that max-width, removing this code will resolve your issue.
 
For an iframe to be 100% height, it needs its parent container to also have 100% height I believe. So can you provide a page that isn't using DMS so we can see it working with 100% height please.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
redstate

I'm confused. I can't figure out why we entered this code in the first place:

 

.entry-title, .entry-content p {
max-width: 560px;
}
 
Before I delete it, can you suggest why we might have done so?

Share this post


Link to post
Share on other sites
Danny

As far as I can remember you want to your title and content on your blog to be a specific width. You can go through your old posts/topics and to see why you asked for it.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
redstate

Great memory! Thanks. Thanks exactly right. At least I have solutions now. I just have to choose which I want to do.

Share this post


Link to post
Share on other sites
Danny

Well you can add page by page styling, try adding the following and see if this gives you a full width iframe.

 

.page-id-6802 .entry-content p {
  max-width: 100%;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
redstate

Just noticed I never responded to you. Would I add this to Custom Less/CSS or elsewhere?

 

Also, did you give me permission to use your child theme? Just what is that? Is it an already designed base theme I can use to avoid many of the set-up steps?

 

Thanks!

Share this post


Link to post
Share on other sites
Danny

Not sure what you mean by give you permission to use my child theme, the child theme I created is open and free for anyone to use regardless of permission.

 

The code above, can be copied and pasted into either your child themes style.less or style.css files and/or in the DMS Toolbar > Custom > Custom CSS/LESS editor.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
redstate

Ok. Thanks. So is your child theme already set up so anyone can just tailor it to our needs?

Share this post


Link to post
Share on other sites
Danny

Yeah, simply install Skeleton and then customize it how you like.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×