Jump to content

Archived

This topic is now archived and is closed to further replies.

kzaiman

Upgrading from DMS2 Basic to DMS2 Pro working in MAMP (local)

Recommended Posts

kzaiman

I'm somewhat new to WP and very new to DMS. I'm fairly comfortable with CSS and HTML.

 

After using the free version of DMS basic, I decided to upgrade to pro using subscription. No matter what I do, it still says I'm using basic. When I click the activate button, it does absolutely nothing. To complicate things further, when I try to return to dashboard, I just get a blank page.

 

Remember to include as much information about your technical issue as possible for example:
Website URL: site is not live yet
Framework Version:
WordPress Version:4
Plugins in Use:unknown / not able to access
Server/Host:local using MAMP
Screenshots:
Details:

To include screenshots or screencasts we recommend 'Jing', its a free cross platform application.
To post code please use our paste service http://paste.pagelines.com and provide us with the URL.

Share this post


Link to post
Share on other sites
Danny

HI,

 

Have you added your license to WordPress Admin Dashboard > Dashboard > PageLines Licenses ?

What version of DMS are you using?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kzaiman

I did add the key, but am not able to access the dashboard now. It is DMS2.

 

Share this post


Link to post
Share on other sites
Danny

What do you mean you added your license but are unable to access the Dashboard ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kzaiman

Sorry Danny. I figured out that MAMP was causing the issue and uninstalled it. I'm now working with AMPPS and was able to download and activate without issue. But when I click on 'customize', I get the following error message:

Fatal error: Call to undefined function ctype_digit() in /Applications/AMPPS/www/wp/wp-content/themes/dms/includes/less.plugin.php on line 2950

Ooops!

Looks like your hosting providers have limited the amount of memory you can use for PHP

You are only allocated 19.27MB.

Anyway at least the fix is easy. Just add the following to wp-config.php and we should be good to go.

define( 'WP_MEMORY_LIMIT', '128M' );

For help with getting DMS up and running don't hesitate to email us at [email protected]

_________________________________________________________________________________

I've added the line of code (without the extra spaces) to the wp-config.php file but continue to get this error.

Any ideas?

Thanks,

Kim

Share this post


Link to post
Share on other sites
Danny

Hi Kim,

 

I have never used AMPPS, I use MAMP and that works just fine for me. There is most definitely no issue with DMS, WordPress running on MAMP, all our team use it. Therefore, the issue had to be related to your configuration of MAMP.

 

In regards to your error above, the  ctype_digit() is a PHP core function and is likely disabled, this is related to AMPP setup, which you will need to resolve. Someone else has reported a similar issue on the WordPress support forums here - https://wordpress.org/support/topic/fatal-error-call-to-undefined-function-ctype_digit

Also, please do not click the Customize button as DMS doesn't support it. If you want to customize your site, please visit the your sites front-end.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Awesome and thanks for sharing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×