Jump to content

Archived

This topic is now archived and is closed to further replies.

jojoking

Can't access DMS editor after going live

Recommended Posts

jojoking

Hi,

 

I develop my website using subdirectory installs for different versions.  Up and till yesterday that meant www.besharptherapy.com/v3 was live, but with the Site URL set to www.besharptherapy.com.  No problems.

 

My new version is in www.besharptherapy.com/v4 and I put it live early this morning.  I changed the setup so that the root index.php file picked up v4 - everything fine.  The site works fine with the v4 subdirectory appended to the URL.

 

When I changed the site URL in wordpress to get rid of the v4, the front end site seemed to work, at least when not logged on.

 

However if I try to go into the DMS editor, it tries to go to a URL like www.besharptherapy.com/v4/v4, i.e. doubling up the v4 tag.

 

At the moment I'm live with www.besharptherapy.com/v4 because at least I can still get into the DMS this way.

 

Do you have any ideas where I can find a solution?  Let me know what else I need to provide to help.

 

Thanks,

Joe.

Share this post


Link to post
Share on other sites
jojoking

Notice: Undefined index: DISABLE_CUSTOM_CSS in /var/www/clients/client1/web1/web/v4/wp-content/plugins/gard-pro/index.php on line 1424 Notice: wp_register_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scriptsadmin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /var/www/clients/client1/web1/web/v4/wp-includes/functions.php on line 3370 Notice: Constant WP_IMAGE_SERVICE_DEBUG already defined in /var/www/clients/client1/web1/web/v4/wp-content/plugins/prizm-image/wp-prizmimage.php on line 95 Notice: pagelines_register_sections is deprecated since version 2.0 of PageLines DMS! Use $editorsections->get_sections() instead. in /var/www/clients/client1/web1/web/v4/wp-content/themes/dms/dms/includes/deprecated.php on line 272

 

 

This is the WP debug info generated when clicking on DMS Editor on the Pagelines admin page in WP.  The URL it goes to is www.besharptherapy.com/v4/v4.

Share this post


Link to post
Share on other sites
jojoking

Seems to be something to do with the Wordpress-HTTPS plugin.  If I deactivate it, I can access the DMS Editor, although the URL attached to the use DMS editor button on Pagelines page now goes to www.besharptherapy.com/v4 which generates a 404 error.  If I then click on the Home page from my site Menu, DMS Editor loads with URL www.besharptherapy.com.

Share this post


Link to post
Share on other sites
jojoking

In fact I didn't deactivate HTTPS, simply the Force SSL Admin option. I could then sign on and the DMS Editor works (if I use the Wordpress Visit Site on the Wordpress top bar).  

 

The DMS Editor button on the Pagelines admin page still goes to www.besharptherapy.com/v4 where the DMS Editor loads but shows a 404 page.  I can live with this, but maybe it could be logged as a bug and investigated?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

When you say DMS editor button goes to /v4 what do you mean, which button ?

 

Also, DMS is installed under the /v4 directory, have you changed your site URL in the WordPress settings ?

Can you enable Debug mode via WordPress Admin Dashboard > PageLines, scroll to the bottom and check the option for Debug mode.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×