Jump to content

Archived

This topic is now archived and is closed to further replies.

werbeagenten_hd

Front-End Editor breaks when more than two plugins are activated

Recommended Posts

werbeagenten_hd

Hey guys,

 

I'm having a problem which I've never encountered with DMS before. When more than 2-3 plugins are active the Front-End Editor and all CSS breaks. However, the CSS problems are only apparent when logged in.

 

There are no error messages in the developer console, PL Debug Info or when using WP_DEBUG.

 

PL Debug Info:

 

WordPress Version

4.0

WordPress Debug

Disabled

Multisite Enabled

No

Current Role

Administrator

Framework Path

/homepages/24/d145919232/htdocs/wordpress/wp-content/themes/dms/dms

Framework URI

http://martina-und-moritz.de/wp-content/themes/dms/dms

Framework Version

2.1.6.1

PHP Version

5.5

WP_DEBUG

No

WP memory limit

120 MB

WP MAX memory limit

256 MB

PHP memory limit

256 MB

Mysql version

5.1.73

WP Max Upload Size

8 MB

PHP POST Max Size

8 MB

PHP Max Execution Time

50000s

PHP type

Cgi-fcgi

WebServer software

Apache

PHP User

U39293392

OS

Linux

Installed Plugins

filebrowser/filebrowser.php

pagelines-updater/pagelines-updater.php

ubermenu/ubermenu.php

 

-------

 

As soon as the Ubermenu plugin is activated the Front-End Editor breaks. After deactivation and a page refresh everything works normally again.. My first suspicion was some kind of php memory error but raising the memory limit had no effect and Wordpress wasn't throwing an OUT OF MEMORY error anyway.

 

I've also tried reinstalling Wordpress and DMS, resetting all FTP permissions etc. but still don't have any clue what's going on here.

 

Any ideas? I've attached a screenshot showing what the page looks like when broken.

 

[attachment=2454:dms_frontend_error.jpg]

 

Cheers!

 

 

Share this post


Link to post
Share on other sites
Danny

HI,

 

UberMenu shouldn't be giving you any issues as it is compatible with DMS when used with the UberMenu section via our shop. So the likely issue is either a server configuration issue or you have other plugins active that are causing the error.

 

When you encounter the issue, are there any errors in Chrome dev tools ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
werbeagenten_hd

Hi,

 

there are no errors in the dev console. 

 

I think I've found the issue causing the problem though:

 

The "?pagedraft=1" CSS file responds with a normal 200 success Status in the dev tools network tab, but the actual content of the file is:

 

<br />
<b>Fatal error</b>: Out of memory (allocated 35389440) (tried to allocate 571989 bytes) in <b>/homepages/24/d145919232/htdocs/wordpress/wp-includes/wp-db.php</b> on line <b>1038</b><br />

 

I still don't know why this is happening though. Wordpress isn't even close to using its PHP limit of 120M.

 

According to a Dashboard Memory Plugin: WP 120M (def) Usage 7% 17.28M of PHP Limit 256M)

 

Any ideas how to fix this?

 

Cheers

 

Share this post


Link to post
Share on other sites
Danny

Well according to the bytes allocated in your error, your server only has 33.75Mb, and it tried to allocate a further 0.54Mb. This displays that your server doesn't have the 120Mb you seem to think you have. It is highly likely that your host has installed a script that allows them to say it has one thing, when indeed it has a completely different value. I recommend you speak to your host as this isn't something we can resolved, the issue is server side.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×