Jump to content

Archived

This topic is now archived and is closed to further replies.

jennajonesdesign

iframes not working consistently

Recommended Posts

jennajonesdesign

Hello!

 

**I already searched the forum and found another gal with a similar issue, so I added a note there as well...

 

My client is a sales rep and is switching to running her whole business online. The program we found to take orders online for a sales rep (WRNTY) only gives me the option of using an iframe to embed the log in for clients. I can see from previous posts that this is less than ideal, but there really is no way around it in this particular situation. 

 

I currently have the iframe in the footer. Really strange - it is working correctly on the home page, but them seems to pull something different on each different page.

 

Any thoughts or ideas on how to fix this? Worst case scenario I just need to get it working in one place and then link to that. But, I can't even get it to work in the content section of the "order online" page. 

 

Anyone have a guess why it is working on the home page and not the other pages?

 

**They had me upload several files. The main file is called "index" so I was wondering is that has to do with it??

 

http://www.tackrep.com/

Share this post


Link to post
Share on other sites
Simon

easy fix, add a / infront of the url

 

/WrntyFiles/Index.htm

 

*not*

 

WrntyFiles/Index.htm

Share this post


Link to post
Share on other sites
jennajonesdesign

aha! So happy and thankful! YAY.

 

Ok, now the only problem is that when the page loads it goes directly to the iframe instead of the top of the page. 

 

Any tips on that?

Share this post


Link to post
Share on other sites
Simon

i think thats because the frame is making the browser focus on it.

Share this post


Link to post
Share on other sites
jennajonesdesign

ok, so no work around? I can just put this on one page if a need to, but it would be nice to have it in the footer. 

Share this post


Link to post
Share on other sites
Simon

Well, maybe the code that is being included could be edited so that it does not force focus.

Share this post


Link to post
Share on other sites

  • Similar Content

    • werdnags
      By werdnags+
      Evening All,
      Can anyone help me please?  I am trying to insert an iframe to wrap another website.  I have tried using the 'text' and 'embed' section and insert the code:
      <iframe src="website-address"></iframe> When I save the page it then returns blank, nothing at all, not even the tool bars for pagelines.  I don;t know how to disable that section so I am having to just delete the page and create a new one with a different name.
      Thanks for any help.
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
×