Jump to content

Archived

This topic is now archived and is closed to further replies.

quintinm

Hiding a section ising page ID

Recommended Posts

quintinm

Hello.

I am trying to hide the fixed area at the top of the page using the ID, but every time i do, it removes the navigation i have in that section for the whole site.

 

As i understand it, i need to place the page ID into the field "Hide on specific pages or posts? (IDs Comma Separated)"

I have just been typing in the page ID as follows.

E.g.

245

 

and when i save and refresh, the navigation inside that section is gone and i need to add it again.

 

Any ideas?

 

Thank you.

 

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

You do not use that ID, in order to hide a an element correctly, you're going to need to first go to DMS Toolbar > Page Setup > Page Handling, here you will see information called Current Page ID copy and paste that ID into the hiding sections field. Publish your changes and when you go to other pages, this area/section will be hidden on that page and that page alone.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
quintinm

Hi Danny, thanks for the info.

Can i hide if for the whole blog section (all pages) of the site?

As it stands it looks like I need to add the ID of every post, the main blog page and each monthly archive page which all have different ID's.

Share this post


Link to post
Share on other sites
Danny

If you want to hide for all blog posts, then you will want to use the type ID instead of the page ID. However, I haven't tried this and I am certain whether it will work or not.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
quintinm

Hi, nope, i don't think it works...

Any other possible ideas as i cannot go back and hide it on each post or archive as they are added.

 

Thank you.

Share this post


Link to post
Share on other sites
Danny

You will need to use either a hook or use CSS. In regards, to CSS try something like the following:

 

/* Blog Page */

.blog .pl-fixed-top,
.blog .fixed-top-pusher {
  display: none;
}

/* Single Posts */

.single .pl-fixed-top,

.single .fixed-top-pusher {
  display: none;
}

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
quintinm

Brilliant, that works on the blog list and single posts.

How would i target the archive pages in the same way?

 

I thought i would try this, but didn't work:

 

.arhive .pl-fixed-top,
.archive .fixed-top-pusher {
  display: none;
}

Share this post


Link to post
Share on other sites
Danny

As far as I can remember it is archive. However, you have it spelt incorrectly in your first rule. Try this instead:

 

.archive .pl-fixed-top,
.archive .fixed-top-pusher {
  display: none;
}

 

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×