Jump to content

Archived

This topic is now archived and is closed to further replies.

Ryan Logan

Background Image Issue

Recommended Posts

Ryan Logan

Hello.  How do we assign a background image to an individual page, have it stretch and stay static (not scroll w/ content) as  seen here

 

In Pagelines Framework, this worked beautifully.  See my live example here.

 

In Pagelines DMS, I'm stuck.  See my live example here.

 

Thank you,

Ryan

Share this post


Link to post
Share on other sites
Danny

Hi Ryan,

 

WordPress includes multiple classes assigned to the body tag on your site, some of these classes are dynamic and different for each page. What you will want to do is use custom CSS prefixed with using the page-id-X class. For example:

 

.page-id-666 {

  background: url(...);

}

 

Additional CSS may be required, but that is how you would have a unique background image on a specific page.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Guest

The Page ID is 39.  I've applied the Custom CSS below and nothing happens.

 

.page-id-39 {
}
 
The URL used for the image path works, if I plug it into my browser.
 
I've also tried....
 

 

Share this post


Link to post
Share on other sites
batman

Hi rlogan

I´m not sure but...

Please, you can try with

  

.page-id-39 {

background-image: url (" YOUR IMAGE");

}


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Aires

Hi rlogan,

 

Give this a try 

 

body.page-id-X .site-wrap {
background-image: url(...)!important;
}
 
~Aires

ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Guest

That places the background on the page, but now I'm back to how things were with my original post.  I need the background stretched to cover the entire page and not scroll with the content.

Share this post


Link to post
Share on other sites
Aires

Hi rlogan ,

 

Give this a try 

 

background-attachment: fixed;
background-repeat: no-repeat;
background-size: cover;

 

 


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Guest

Thank you.  I'm extremely close to having the same results.  It will probably have to do.  Something is still a little off (the bottom of the image looks different between the sites) but maybe that's just part of switching from Framework to DMS.

Share this post


Link to post
Share on other sites
Aires
Can you post some screenshots
Sent from my Windows Phone using Tapatalk

ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Aires

rlogan Looks like the cover may have blown up the image a little

 

Try this and see if it looks any better

 

  background-size:100%;
  height: auto;
  max-width:100%;  //this may not be needed
  background-attachment:fixed;
  background-repeat:no-repeat;
 
~Aires

ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Guest

No dice.  Tried w/ and w/o the max-width setting.  Appreciate your help.  Facing a bigger issue with this same site...migrating from Framework to DMS.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×