Jump to content

Archived

This topic is now archived and is closed to further replies.

tsalstrand

DMS2 Config Import - Not Importing Templates

Recommended Posts

tsalstrand

I'm migrating a client's dev site (http://haco4.convertwith.me) hosted on Hostgator to their soon-to-be live site (http://haco.us.com) on Media Temple DV. 

 

The problem I'm having is that the file I'm importing into the new site (using DMS's import config utility) brings everything over EXCEPT the page templates. I thought it might be because the export config file didn't have them in it but after checking it I can see they're there. (here is a copy on Google Drive: http://goo.gl/srGrjF). 

 

I can't figure this out... can someone help me? I need this site to go live this weekend so any help would be greatly appreciated!!

 

Thanks,
Steve

Share this post


Link to post
Share on other sites
tsalstrand
4 hours and still nothing? This is not where I ever plan to spend so much time in site design. Can any admins help?

Share this post


Link to post
Share on other sites
tsalstrand

Simon_P"] or @[member="Danny - please, any help tonight? Site has to be live for a conference tomorrow and I'm at a loss - for the past 24+ hours I haven't been able to figure this out.

Share this post


Link to post
Share on other sites
Danny

HI,

 

Are you attempting to import templates created in DMS 1.x to DMS 2.x ? If this is the case, as far as I am aware, due to the changes in DMS 2.x templates, the templates will not import. I have mentioned this on our tracker.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Can you disable all active plugins, remove any custom code or scripts you may have added and then record yourself exporting the file and then importing the file please. Also, can you send us or upload your exported file (when no plugins or code are installed/added) so we can test the import ourselves please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tsalstrand

Danny, Hey Danny. I didn't see your original response. I'm still having this issue. 

 

I've uploaded a screencast here: http://screencast.com/t/ELAtzGMY

 

The exported file is here (Pagelines paste subdomain is down):  https://drive.google.com/open?id=0B6hcmWeYqPx-UHRWNjNmYWp3OUU&authuser=0

 

Please let me know if you can help.

 

Thanks,
Steve

Share this post


Link to post
Share on other sites
tsalstrand
Simon_P"] or @[member="Danny - Could this be an issue with the DMS export/import utility not supporting this number of templates?

Share this post


Link to post
Share on other sites
tsalstrand

Well, I tried just exporting the Home Page template, Global Settings, and Post Type Settings. Yet it still doesn't work. The export file looks fine, but the new Pagelines DMS install won't import the json file with templates. But it does bring in the global settings/custom code. 

 

Where are the template files in the DMS install found? I can just copy those files and FTP them into my new live server environment. 

 

I'm more than willing to give login access to an admin/mod if you'd like to try. Please let me know. I just need to get this fixed quickly.

 

Thanks,
Steve

Share this post


Link to post
Share on other sites
Simon

Interesting. max_allowed_packet is a MYSQL setting, usually set in my.cnf and the default is 16M is your config bigger than that?

Share this post


Link to post
Share on other sites
tsalstrand

Correct, it is a mysql setting, set in my.cnf. For this client site, we setup a DV on MediaTemple. MediaTemple defaults to 1M. The json file size was about 8M. 

 

Unfortunately DMS gave me no feedback when I tried to import through the frontend. It wasn't until I tried to import it in via phpmyadmin that I got the max_allowed_packet error. One suggestion I would have is that DMS have error handling (if possible) for import issues like this. It's probably only 1 in 10 servers that have the max_allowed_packet set so low, but in the case of Media Temple they are the last hosting company that I would expect to have something like this to happen.  I've had it happen on Rackspace Cloud servers as well.  

 

Not DMS's fault at all, but if it could have error handling for when the import wasn't done completely, that'd be most excellent. 

 

Hope this helps anyone else that might come across the same problem.

Share this post


Link to post
Share on other sites
Simon

Would you be able to email me the config so i can test it locally? 

Share this post


Link to post
Share on other sites
tsalstrand

Sure. Do you want the json config for DMS or a the my.cnf for mysql or a different one?

 

Thanks,
Steve

Share this post


Link to post
Share on other sites
Simon

Just the json config

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×