Jump to content

Archived

This topic is now archived and is closed to further replies.

nizami

DMS Template Problem Wipes Site Again

Recommended Posts

nizami

Just logged into my client site to make the finishing touches and publish, only to discover that, somehow during several weeks of inactivity, the template problem has mysteriously reappeared and wiped all content again. The pages are there in WP, and the products are there in Woo, but all DMS templates are gone, replaced by this error message: 

 

Warning: Invalid argument supplied for foreach() in /home/content/77/12052677/html/wp-content/themes/dms/dms/editor/editor.templates.php on line 313

 

Any help very much appreciated! 

 

 

Share this post


Link to post
Share on other sites
nizami

OK so flywheel backup hasn't solved this...is there anything I can do other than wipe the site totally clean–fresh install of WP/DMS/everything??? Not sure I can face doing that yet again. Danny, you kindly logged in to my site and made a test page. I'm not pointing any fingers, but according to this post a potential source of this bug is to do with multiple admins. What do you think? 

 

Best 

 

N

Share this post


Link to post
Share on other sites
Danny

I can't believe that multiple admins is the cause, as we have several admins on PageLines.com, who have all contributed to PageLines.com and therefore, used the DMS visual editor at some point. So for me that isn't an issue, I will certainly check this out on my local installs, but in all honesty that isn't the cause of the issue.

 

On your site, what plugins are you using please list them all and also have you added any custom code or changed any files at all ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nizami

Hi Danny: 

 

DMS Pro Tools 1.6.2

Pagelines Updater 1.1

WooCommerce 2.1.12

 

haven't added any custom code, and haven't touched the site since we last spoke about it and I marked the thread problem solved. 

 

 

Share this post


Link to post
Share on other sites
Danny

What is the issue resolved? If so, what was the cause ?

 

If you're running the latest version of DMS, WordPress, using no plugins except the ones that listed above, have added no code snippets and are hosted by FlyWheel, then our developers would love to see a video of your issue. As you shouldn't be having the problem you have.

 

A quick question, if my memory serves be correctly, did you not migrate from another host to FlyWheel ? If you did, did they perform there free migration or did you just install a fresh copy of DMS into your new FlyWheel account ?

 

As that is the only thing I can see that would cause your issue, as everything else is pretty much perfect, update to date DMS, WordPress and plugins, hosted by an awesome host and no customization changes.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nizami

Danny I assure you everything is as I have already said. I built the site from scratch–––fresh install of WP, then DMS, then all the build when I moved to Flywheel.

 

Having built the site, from scratch, by hand, in DMS, FIVE TIMES OVER, I am simply not prepared––indeed, it would be Einstein's definition of insane–––to attempt it again, with no guarantees that the same thing will happen. From my POV––if you can understand this––the only guarantee based on past experience is that at some point DMS will break, and I will lose all my work again. 

 

Your message above leaves me no options at all. Perhaps you're out of ideas. If so, could you please refer me to a different moderator?

 

I'm sure you'll understand my position. I just billed my client for 2 years FlyWheel hosting, showed her a working website which she loved and is now waiting to show her audience. At the last hurdle DMS has broken and quite possibly killed the project, which is from my POV totally unacceptable. 

 

I need to make some decisions fast. I really hope we can work this out. :-)

 

N

 

PS Please be clear: I am not attacking DMS. I love the product and desperately want it to be my WP-platform of choice. Therefore, please stop defending your product. 

Share this post


Link to post
Share on other sites
Danny

I am going to bring your topic to one of our developers attention, as I am simply unable to recreate your issue. Like I said, I have tons of test sites all running different plugins, layouts and configurations and some of these, I haven't touched in months and when I have just revisited them, they're all intact and how I left them.

 

Usually something like this, is either caused by plugins or a poor host or configured server, with you using FlyWheel, this isn't the case. So, can you provide some more information please and then I will speak to one of our developers.

 

Are you sure that the plugins you have listed above are the only ones active ?

What has actually be wiped, content, users, templates, orders etc... Can you provide a list of everything that has been wiped please.
Are you running the latest version of DMS?

Have you added any custom code of any kind i.e. scripts, php via functions.php file and/or CSS/LESS CSS ?

Have you made any changes to any of the core files ?

Are you using a child theme ?

Can you enable DMS debug mode and provide a link to the site in question please.

 

Update: Just noticed you provide some of this information already on the other topic, can you keep your responses to this topic, as the creator of the other topic will be getting emails each time there is reply.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nizami
Here's the environment info again, copied from the other thread. Have you had a developer look into this yet? You've been promising that for some time.
 
## Environment ###
 
Home URL:                http://jackielewis.co.uk
Site URL:                http://jackielewis.co.uk
WC Version:              2.1.12
WC Database Version:     2.1.12
WP Version:              4.0
WP Multisite Enabled:    No
Web Server Info:         Apache
PHP Version:             5.3.24
MySQL Version:           5.5.37
WP Memory Limit:         40 MB - We recommend setting memory to at least 64MB. See: Increasing memory allocated to PHP
WP Debug Mode:           No
WP Language:             Default
WP Max Upload Size:      32 MB
PHP Post Max Size:       33 MB
PHP Time Limit:          30
PHP Max Input Vars:      1000
SUHOSIN Installed:       No
WC Logging:              Log directory is writable.
Default Timezone:        Default timezone is UTC
fsockopen/cURL:          Your server has fsockopen and cURL enabled.
SOAP Client:             Your server has the SOAP Client class enabled.
WP Remote Post:          wp_remote_post() was successful - PayPal IPN is working.
 
### Locale ###
 
decimal_point:           .
thousands_sep:           
mon_decimal_point:       
mon_thousands_sep:       
 
### Plugins ###
 
Installed Plugins:       Akismet by Automattic version 3.0.2
                         DMS Professional Tools by PageLines version 1.7.1
                         PageLines Updater by PageLines version 1.2.1
                         WooCommerce by WooThemes version 2.1.12
 
 
### Settings ###
 
Force SSL:               No
 
### WC Pages ###
 
Shop Base:               #42 - /gallery/
Cart:                    #43 - /basket/
Checkout:                #44 - /checkout/
My Account:              #45 - /my-account/
 
### WC Taxonomies ###
 
Order Statuses:          cancelled (cancelled)
                         completed (completed)
                         failed (failed)
                         on-hold (on-hold)
                         pending (pending)
                         processing (processing)
                         refunded (refunded)
 
Product Types:           external (external)
                         grouped (grouped)
                         simple (simple)
                         variable (variable)
 
 
### Theme ###
 
Theme Name:              DMS
Theme Version:           2.1.5
Author URL:              http://www.pagelines.com/
 
### Templates ###
 
Template Overrides:      No overrides present in theme.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
×