Jump to content

Archived

This topic is now archived and is closed to further replies.

alisamski

Menu indicators & Web URL

Recommended Posts

alisamski

Question?

 

Web viewing and menu indicators do not show up when adding a www in front of my url?

 

Suggestions?

 

http://bit.ly/1umjnRq

Screen shot attached.

 

[attachment=2408:menu-inducatir.png]

Share this post


Link to post
Share on other sites
Simon

Thats because when the CSS was compiled, you were logged into NON-WWW.

 

You must choose which one you are going to use, and redirect from the other. Non redirected www means you have 2 websites, google will penalize you.

Share this post


Link to post
Share on other sites
alisamski

Is that a DNS issue? from the host and name servers?

 

A.

Share this post


Link to post
Share on other sites
Simon

No, its up to you to decide whether to use www or not, then setup a htaccess file to handle it.

 

If you are going to just use www, make sure www is in the URLS in wordpress settings.

Share this post


Link to post
Share on other sites
alisamski

Simon thanks for helping with this... as never had to deal with it before...

 

ok... so we have no www. access in wordpress settings...

 

host is set up without the www.  and that is what we were told to use..

 

what would we need to add to the htaccess?

 

A.

 

 

 

 

Share this post


Link to post
Share on other sites
Simon
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

Share this post


Link to post
Share on other sites
alisamski

Wow...

 

why did I not have to do this before?????

 

Is this standard?

 

Share this post


Link to post
Share on other sites
Simon

updated with right code

Share this post


Link to post
Share on other sites
alisamski

Wow...

 

Is this standard?

 

Never had to mess with the .htaccess for a redirect before.

 

Share this post


Link to post
Share on other sites
Simon

Depends how your host is setup.

Share this post


Link to post
Share on other sites
alisamski

Simon_P

 

So... there was a problem with the clients internal server....

and we now had to set the wordpress settings to www...

 

How would I re-write that redirect code from what you sent me:

 

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

 

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
×