Jump to content


This topic is now archived and is closed to further replies.


Disappearing Sections in Canvas Areas

Recommended Posts

Framework Version: 2.1.5
WordPress Version: 3.9.2
Plugins in Use: Askimet, Custom Sidebars, DMS Pro Tools, Enforce Strong Password (Forced and required by host), and Pagelines Updater
Server/Host: WP Engine
Screenshots: Click Here for PDF
Hello folks, we're having a problem saving a Canvas Area in the Header Region after hiding it on our home page. Here's the gist:
  1. On our home page, a Canvas Area is placed inside the header region. Area padding, bottom padding, and background color are adjusted.
  2. A Column Section is Cloned from the template region below and placed inside the Canvas Area in the Header Region. The cloned Column includes a Widgetizer Section along with a Text Box Section.
  3. The Canvas Area in the Header Region is then set to be hidden only on the home page.
  4. The home page is refreshed and indicates that the Canvas Area is now hidden. The changes are published.
  5. I navigate to another page and find that the Canvas Area is now empty.
  6. On the home page, I delete the ID of the home page to unhide the Canvas Area. The home page is refreshed and the Canvas Area is now empty as well.
I've highlighted the steps in a PDF document. For the record, WordPress caching is turned off server side and the issues persists before and after activating the various other plug-ins we would normally use in our WordPress install.

Share this post

Link to post
Share on other sites


Would it be possible for you to record the issue please so I can get a better understanding. We recommend either QuickCast or Jing.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?