Jump to content


This topic is now archived and is closed to further replies.


Custom shortcode used in text box outputs before div.textbox-wrap

Recommended Posts




Basically shortcode with code (posted below) in child's theme functions.php outputs outside textbox. Just before div.textbox-wrap and after div.pl-section-pad ::before.


When enclosed with [pl_raw] not outputs at all.


No formatting added even if used in wp_content.


If enclosed in <div> - div doesn't appear.

function reflink_func( $atts ){
	$uids = get_users(
        'blog_id'  => get_current_blog_id(),
        'role'     => 'administrator',
        'fields'   => 'ID',

$url = add_query_arg( 
    array( 'ref' => join( ',', $uids ) ), 

$link = '<a class="icallout-action btn btn-success btn-large" style="text-align: center;" href="' . $url . '">ЗАРЕГИСТРИРОВАТЬСЯ В ПРОЕКТЕ</a>';

echo $link;

add_shortcode( 'reflink', 'reflink_func' );

Please help. It should be displayed just as a regular button.


Thanks ahead!

Share this post

Link to post
Share on other sites



just used return instead echo and all works. Sry for posting.

Share this post

Link to post
Share on other sites

Golden rule, shortcode functions are filters, filters must always return something. :)

Share this post

Link to post
Share on other sites

Ah, what can I say? I'm very bad at php. Because very new to it. Thanks for advice - from now on will use return in shortcodes!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?