Jump to content

Archived

This topic is now archived and is closed to further replies.

alisamski

DMS JQuery version: Plugin Conflict

Recommended Posts

alisamski

Hi,

 

Trying to implement a plugin... (before you say anything about support)... I've been thru the plugin developer and this is what they say...

 

Exit Box Plugin: does not play nicely with DMS Editor....

 

 

Developer Says: The error is generated by your theme when it tries to extend a standard jQuery ( jQuery.extend.swing ). that is a standard jQuery effect and not a part of ExitBox, My guess is that your theme was designed for an older version of jQuery.

 

URL in question with external linking: http://bit.ly/1tpuk4b

 

Please advise.

 

Share this post


Link to post
Share on other sites
Simon

What isnt working? https://cloudup.com/cTwyj_fwH8i Thats the lite version and the DMS editor working.

 

DMS does not use and version of jQuery, it makes use of the bundled version that is part of WordPress. 

Share this post


Link to post
Share on other sites
alisamski

Simon_P Purchased the pro version... and the DMS editor in Chrome does not load... (which I can send you to test)??

Been working with the developer and he's been sending several versions for me to try... can it be the Php Version the site is on?

 

Let me know which email?

Share this post


Link to post
Share on other sites
Simon

Send to simon @ pagelines dot com 

 

Hopefully the pro version is coded better than the lite version, i had to turn off debugging because the page was full of php warnings. 

Share this post


Link to post
Share on other sites
Simon

Well, after a quick look, the 'thickbox' setting works ok..

 

The plugin turns link like this: <p><a href="http://google.com">google</a></p>

 

into this:

<p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><a href="http://dms-theme-2?xb=%3A%2F%2Fgoogle.com" rel="nofollow" class=" fancyexitbox" id="exitbox50587"></body></html>
google</a></p>

.. which is mind boggling, what is with the doctypes???

Share this post


Link to post
Share on other sites
alisamski

Decided to trash it....  too much lagtime when loading pages etc...

 

aaaack I spent way too much time on this...

 

Thanks Simon...

Share this post


Link to post
Share on other sites
Simon

Yea was overkill really 

Share this post


Link to post
Share on other sites
alisamski

So basically I'm trying to just do a basic overall sitewide popup when clicking on an external link (via the financial compliance requirement)...

However, I need it to go to the url afterwards...

 

I'm not seeing the DMS Modal popup ability to do that...

 

unless I'm missing something?

Share this post


Link to post
Share on other sites
Danny

You will probably want to use a lightbox or similar plugin, these plugins usually include a class which triggers the lightbox effect. You will want to use this class on all your external links.

I think the best course of action would be for you to ask this question on the WordPress support forums, as this isn't a theme specific issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alisamski

Danny Thanks will do.

Share this post


Link to post
Share on other sites

  • Similar Content

    • werdnags
      By werdnags+
      Hi Folk,
      Can anyone help me please.  On a page on my site I placed an 'embed section' and inserted code from the Eviivo Booking system that seems to call scripts from their site.  After doing the PL5 editors will not load so I can't edit anything.  Is there anyway of disabling the section so I don;t have to rebuild the page?
      Thanks.
    • chamois_blanc
      By chamois_blanc+
      Please see screenshot. I think it should be self-explanatory.

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • Peter Esslemont
      By Peter Esslemont
      Hi,
      When using the editor I am getting duplicate wordpress toolbars and an a nice error to go with it...
      I have them stack 4 high at one point.  Goes away with a refresh then re-appears.
      very odd.

       
       

    • cas45
      By cas45+
      I am running a site based on PageLines Framework 2.5.0. I am making some changes to a current website and managed to find a script that will do what I want.:
       
      $(".vend-cat").each( function() {
          if ( $(this).find(".no-vendors").html() == '' ) {
                 $(this).hide();
          }
      } );
       
      I have tested it on jsfiddle and it works fine. It does however need to be adapted to work with jQuery for pagelines and wordpress. Any help or advice?
       
      Thanks
×