Jump to content

Archived

This topic is now archived and is closed to further replies.

Michael_J

Single Bits - question about WP Content setup

Recommended Posts

Michael_J

ellenmva,

I just posted a question but it didn't show up so I'm sending again. Apologies if it gets replicated. And sorry about the "topic prefix", none of them fit so I just chose 'filtering'. This is about Single Bits.

 

Here's a link to the site:  http://www.qamera.com

 

First of all, I love it!  Works great on individual post pages - except one small thing, it seems to cut off the top part of the feature image. All of my feature images are 3:1 aspect ratio.  Attached images illustrated.

 

Also, wondering how to achieve the same on the landing page of my blog? I.e., show the featured image of the most recent post, across the top?

 

DlplEZI.jpg

 

 

9mNalPE.png

 

Share this post


Link to post
Share on other sites
ellenmva

Michael_J Glad you like Single Bits, it's just the start. I plan on building on to it over time as people find ways to use it on single posts and pages and make suggestions and feature requests. Great photography and nice start to site! We need to get the Featured Image displaying properly to showcase your photography.

 

It looks like you may have found a bug with the padding on the Single Bits Container.  If you don't change the option in the Single Bits Container Settings the container should have default top and bottom padding of 20px. When I add that default padding, your head is not cut off in the image.

 

I'll fix the bug (have another small one too) and push out an update today. Will let you know when fixed. 

 

Having said that, there still may be some adjustments to make, either with some CSS, changing one of the image sizes or adding a custom image size. I will help you get it right, it will give me a use case on ways to work with Featured Images as Background.

 

As for having the most recent post show on the Home Page with the full-width featured image that can't be done with Single Bits. I have however created a custom section for a client that could be modified. Let me look into it, see how much work it would take to make it generic for anyone looking to have the first post on the Blog/Home page show the full-width featured image as background.

 

Best,

 

Ellen

 

 

 

 

 

 


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
ellenmva

Michael_J Okay, got it sorted. Thought I had it fixed with version 1.0.1 but then found the real problem which is the padding wasn't being added to the style unless there were some sections inside the Single Bits Container. So, up one decimal of a version to 1.0.2.

 

If you need more assistance with image styling let me know, it's one of  the tougher areas in web design especially when on formatting for tablet and smartphone screens.

 

I'll look at the full-width image for first post on Blog/Home page in the next couple of days and get back to you.

 

Best,

 

Ellen

 


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
ellenmva

Michael_J The update for Single Bits should show up in your wp-admin Dashboard --> Updates. You should see it there. If not, let me know and we'll go from there.

 

WordPress_Updates_%E2%80%B9_DMS_1_2_%E2%

 

Best,

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Michael_J

ellenmva got it, sorry. but after updating, it now longer shows up in my sections list. Am I missing something? I tried to uninstall then install, but that did not work.

 

 

B0DObfm.png

Share this post


Link to post
Share on other sites
Michael_J

ellenmva ok seems fine now! took some moments to refresh.

Share this post


Link to post
Share on other sites
ellenmva

Michael_J Super! 

 

I haven't forgotten about your other question about having the first post in the Home/Blog page to be full width with featured image as background. Trying to see if there is an easy way where it is a separate section that does that one thing and then you keep the post loop section you are currently using and make it not show that first post again, or if need to make a completely new post loop section. Hopefully the former.

 

Best,

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Michael_J

ellenmva excellent; flipper is not workiing for me and the CSS I added is not working. 

Share this post


Link to post
Share on other sites

  • Similar Content

    • JudithKlinger
      By JudithKlinger+
      Help! I urgently need to remove the "This post was last edited..." that is now appearing anywhere that I've used Single Bits for a post. 
      James Giroux kindly provided this reply...but it does nothing. HELP! 
      This is from the Single Bits section by Ellen.  The code to add to the functions.php to remove this is:
      if(class_exists('elsueSingleBitsPlugin')) { $instance = elsueSingleBitsPlugin::this(); remove_filter('the_content', array($instance , 'add_mod_hatom_data'), 5 ); }
    • JudithKlinger
      By JudithKlinger+
      I'm stuck in a loop. We're developing a magazine type format and having been using Single Bits Single Post as the template..fine, no problem. Looks great! 
      But, some of the articles now have either a lot of media, or multi media, so we wanted to set up another template for these posts. But, if I change the media content on one post, it 
      changes it on the others. I've tried setting up Custom Posts, but that removes the post from the wp post "categories" and then deletes the post from something like HoverNews that pulls by category. 
      So how do I have the media change for each post? I've tried setting up a separate template for each of these particular, media specific posts...but that doesn't help either because they are posts, not pages. 
      Can PM you the link as the site is not live yet. Thanks!!
    • stoltz
      By stoltz+
      I want to change the text color of the post title in a specific post - How do I do that through CSS?
       
      I've downloaded a plugin which allows me to add custom CSS in specific posts, but I do not seem to get the selectors right.
       
      I am using the light-bg class on the single-bit container as well, which then includes a single-bit with the post title.
       
       
       
       
    • flourishdesignstudio
      By flourishdesignstudio+
      I am working on a website right now that uses custom tab colors that also match the background color of the tab content area. However, when a tab is open the tab bg color appear slightly different than the bg of the content area. I have double checked all my setting and can't seem to find a way to override this. 
       
      Would a link be helpful so you can see what I am referring to? I will include a screenshot in case that works...
       
      Thank you so much for all your help!
       
×