Jump to content

Archived

This topic is now archived and is closed to further replies.

Dominik

Google Maps: get Locations from CPT

Recommended Posts

Dominik

Is it possible to add a function to the google maps section to get the Locations from a Custom Post Type?

 

I have a cpt called hotels with fields: google maps address, google maps title, google maps description

for the single hotel view i could use the fields with the maps shortcode to display the map fine.

 

 

i want the google maps section to display all entries of the cpt on one map in the hotel overview (archive page) 

i should lode the, address, title and description from the cpt.

 

nice add-on would be possibility to select the custom taxonomies to display

 

 

Or is outthere a plugin possible doing this all?

 

 

Share this post


Link to post
Share on other sites
circ2013

Hi Dominik,

 

Did you ever figure anything out here?  I have a similar issue where I have a client that sells there products in stores across the US and I would love to create a custom post type for each location and have them display on a map.

 

Thanks,

Scott

Share this post


Link to post
Share on other sites
Dominik
Hi, yes i got it working with mappress pro Plugin. IT offers a mashup Map where you can query what you Need

Share this post


Link to post
Share on other sites
Danny

Dominik - Thanks for sharing that plugin, looks cool.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
circ2013

Dominik,

Just wanted to circle back here to say thanks.  I just now got around to updating my map solution to Mappress Pro.  I did as you recommended to query from a CPT then generate a Mashup map and it worked perfectly.

Thanks again,
Scott

Share this post


Link to post
Share on other sites

  • Similar Content

    • flourishdesignstudio
      By flourishdesignstudio+
      Hello,
      I am experiencing an issue that I believe is theme related where two areas on our homepage are not loading correctly, until you resize the browser window. I am currently building http://stevesaggese.com/ but on the bottom of the homepage there is a google map and a "Featured Area Photos" slideshow that are not displaying properly. For example, in EI or Firefox the map is zoomed all the way out instead of zooming in on central New York. The are beneath that is "Featured Area Photos" and the images are loading as thumbnails instead of full (half column) images. When you simple make the browser window slightly large or smaller the photos adjust to be the correct size.
      If I switch themes the issue seems to disappear and I have tried deactivating certain plugins to see if that has any effect too. Is this a JS loading issue or something else caused by the theme?
      Thanks in advance for any help you are able to provide.

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
×