Jump to content

Archived

This topic is now archived and is closed to further replies.

ketri

Modal is in front of page and blocks CTA

Recommended Posts

ketri    7
ketri

Hi

You can see my problem here: https://www.dropbox.com/s/0t0fe6itgceorbx/Screenshot%202014-08-15%2012.07.57.png

So I have a modal. And even though it's invisible it's still there and blocks call to action buttons. 

 

I've inserted the modal in my functions.php useing pagelines_before_site -hook: 

add_action('pagelines_before_site', 'beforeSite');
    function beforeSite() { ?>


<!-- Modal -->
<div class="modal fade" id="modaali" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
  <div class="modal-dialog">
    <div class="modal-content">
      <div class="modal-header">


        <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">×</span><!--<span class="sr-only">Sulje</span>--></button>


        <h4 class="modal-title" id="myModalLabel">Ensimmäinen askel otettu!</h4>
      </div>
      <div class="modal-body">
<p class="leadi center">Jätä sähköpostisi tai puhelinnumerosi niin katsomme yhdessä kuinka Bitcoin voisi hyödyttää liiketoimintaasi.</p>
<?php echo do_shortcode( '[contact-form-7 id="44" title="Ei otsikkoa"]' ); ?>
      </div>
   <!--   <div class="modal-footer">
        <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
      </div>-->
    </div>
  </div>
</div>


    <?php
}

Is this how the modal should be working or is there a bug somewhere?

Could you give me a step-by-step instruction on how to use the modal so it's not there when it's hidden?

The site is not visible since I don't want to release a version where users cannot use the CTA, but I will if it's necessary for debuging.

Thank you!

 

Share this post


Link to post
Share on other sites
ketri    7
ketri

Ok. I noticed that when I open it and close it, it then works. It was because it didin't have style="display:none" by default.

So I inserted style="display:none" to the modal and now it works. 

Is there a tutorial for the modals somewhere?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

The issue is likely your code, as there is no issue when I use the modal shortcode, which is what we recommend you use. We do not provide support to user created code unfortunately.

 

If you want a tutorial on how to use modals, you will want to read the Bootstrap 2.x docs. which is what we use.

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • Jesper
      By Jesper+
      Is there a way to create modal popups? It was possible ind DMS2
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
×