Jump to content


This topic is now archived and is closed to further replies.


Adding Social Icons to Fixed Navi Bar

Recommended Posts




I am working on a website and the cleint really likes the Navi fixed to the top as it is standard within DMS2.  They really wish to have 3 social icons, Facebook, Twitter & Youtube displayed on the Nabar either to the left or right of the menu items.


Can anyone recommed a way to do this?  My original thought was to create a branding section but since that's not fixed the client doesn't like that option.


Thank you - Chules

Share this post

Link to post
Share on other sites

Hi chules

You can use the "font awesome" in your menu, for example this for Facebook



and you use this in te navigation level with 

<i class="fa fa-facebook"></i> 


You can see 





Life is too short to remove USB safely ...

Share this post

Link to post
Share on other sites

I am making progress with this.  You can see my progress on the site I'm working on at htt://dev.sportscare1.com.  I am using the hide my site plugin and have set the password to "password123" without the quotes for you to see the issue I'm having.  I took the instructions above and combined this with the Pagelines Tutorial on Creating a Branding Area found here, http://forum.pagelines.com/topic/36301-adding-social-icons-to-fixed-navi-bar/.


When I try to style the social icons by adding the colored backgrounds my navibar menu becomes corrputed with spacing between the menu items and the loss of the drop down arrows for sub navigation.  Here is the code I'm using in my DMS2 Less with comments on what block of code is causing the issue.

/* Social media color variables this code does not cause an issue */
@facebook:          #3B5998;
@twitter:           #00ACED;
@youtube:           #CD332D;

/* When I add this code my navi menu becomes corrupted*/
.icon {
      .border-radius(0px); // Here in-case you wish to add a radius
      margin-bottom: 5px;
      min-width: 36px;
      color: #FFF;
      text-align: center;
      font-size: 16px;
      line-height: 36px;
 &:hover { .transition(background 400ms linear); }

.icon-facebook {
      background-color: @facebook;
&:hover { background-color: lighten(@facebook, 10%); }
.icon-twitter {
      background-color: @twitter;
&:hover { background-color: lighten(@twitter, 10%); }
.icon-youtube-play {
      background-color: @youtube;
&:hover { background-color: lighten(@youtube, 10%); }

If anyone can take a look at this and point me in the right direction it would be great.  Thank you - chules

Share this post

Link to post
Share on other sites

The password isn't working for me, so I can't see what your issue is.


The code you're using above is what I wrote on how to create a branding section in our docs. If you want to add a colored background to your nav items then you will need to target the menu items themselves by inspecting the menu item and using the unique ID.


For example:


.menu-item-55317 { background-color: red; }

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?