Jump to content

Archived

This topic is now archived and is closed to further replies.

alisamski

external links calling javascript

Recommended Posts

alisamski
function leaving(url){ 	if(confirm("You are now leaving the The Federal Credit Union web site.nnWhen you click 'OK' you will be entering a website hosted by another party. Although this institution has provided this link you will no longer be subject to, or under the protection of the privacy and security policies of The Federal Credit Unions website.nnWe encourage you to read and evaluate the privacy and security policies on the site you are entering, which may be different than those of The Federal Credit Union.nnThe Federal Credit Union is not responsible for the content of the website you are entering. The Federal Credit Union does not represent either party if transactions are entered into between the member and the other party website host.nnIf you would like to proceed click 'OK'. Click 'Cancel' to return to the website")) 	{ 		window.open(url, 'newWin'); 	} }//end function 

Working on a financial site, and they require a pop up with confirm on external links..

This is what they had in place, however, I'm not sure where to put it in the theme...

 

I tried in the custom code section however that did not work... this code just showed up at the top of my page in the header...

 

Please advise.

 

Thank you.

 

 

Share this post


Link to post
Share on other sites
Danny

When you added that to the custom code area, did you just copy and paste or wrap the code with script tags ? If you're having issues with custom code, you will need to speak to the developer of the code for assistance, this isn't something we can provide support for.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alisamski

Danny I did not wrap it... just as you see it above...

 

I also did this via the functions file... however, it white-screened it... so I'm gathering that I am not adding correctly...

Share this post


Link to post
Share on other sites
alisamski

Danny and most importantly... I tried using the modals... however I'm not seeing how to apply them site wise for external links...

 

FYI.. I just have to say this... as a "long-time user & buyer" of the themes you folks create....(going back to platform pro 2010-2011...)

 

You have not answered my question.... you just commented and marked it answered... please don't do that...

 

It shows disrespect to your customer.

 

The climate of this forum has indeed changed. geesh.

man... grab another cup of java.

Share this post


Link to post
Share on other sites
Danny

I am by no means showing you disrespect and I did indeed answer your question. The issue you're having is that you have not adding a script correctly, you can not just copy and paste code and expect it to work.

 

If you're going to add a custom script to the DMS Toolbar > Custom Code options area, then you can not add it in the way you have, as that will only cause issues. You will need to try wrapping the code with script tags, if that doesn't work you're going to need to speak to the author of the code.

Our forum policy has never changed, we do not provide extensive customize support and this is what this is, we have also never provided support for external scripts or code which cause issue. You will always need to speak to the author of the code.

 

You can also use the following to add your script to WordPress - http://codex.wordpress.org/Function_Reference/wp_enqueue_script


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alisamski

So now you have answered the question.... about needing to add the script tags... before you left it open if I did or didn't... and not explaining it... and marked it answered.

 

Let's also be clear.... when you have a "customized code" area within a theme... it is an area that should be supported by the theme developers/staff/moderators...

if I am trying to use that area to insert code... it should be covered under tech support if I am not adding it correctly within that area...

If I have added it correctly and it does not work... then that is another thing.

 

I'm not speaking of the code itself, but by the means it is added to the theme. FYI, I have been instructed before about using the functions file and how to add it there... So perhaps it is just that you do not have time to take the time. ;-)

 

I am also aware of what is covered here on the forum... been here for years... and yes, it has changed... and yes I have hired pro developers here also for extensive and not so extensive coding.. and I have dealt one on one with some of the moderators/staff/developers here to help me get through an issue... so I can say it has changed from first hand experience.

 

Thanks Danny for your help, I'll take it from here.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×