Jump to content

Archived

This topic is now archived and is closed to further replies.

illinimatt81

Theme Errors -- Using Excessive Resources

Recommended Posts

illinimatt81

Hello,

 

This morning my host had suspended my VPS account due to excessive resources being used. We have identified that somehow in the latest version of DMS 2.1.5 there is a conflict with a mission critical plugin 'Pilot Press' from Ontraport that powers our eCommerce, CRM, membership site access integration with Ontraport. The link to the plugin is here: https://wordpress.org/plugins/pilotpress/

 

We have since disabled that plugin and the host restored my site. They have been working with me along with Ontraport over the past few days in tracking down what has been going on as this started last Tuesday.

 

This morning we obtained a new clue to the issue and it involves Pagelines code.

 

I'm looking for support in identifying what might be causing Pagelines to throw errors and use excessive resources when the Pilot Press plugin is activated. Prior to last Tuesday, we had the plugin and DMS working well together without issue so something changed. There have been no updates to the Pilot Press plugin.

 

The errors at fault are noted below:

 

------

| Top Process | 62.0 | /usr/bin/php |
| Top Process | 57.1 | /usr/bin/php |
| Top Process | 51.2 | /usr/bin/php |

In the public_html root, the site is constantly logging site errors, excerpt below:
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 85
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'val' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 58
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 82
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 85
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'val' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 58
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 82
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 85
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'val' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 58
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 82
[12-Aug-2014 06:58:30 UTC] PHP Warning:  Illegal string offset 'type' in /home/mejohns1/public_html/wp-content/themes/pagelines/includes/class.css.php on line 85

Any help/troubleshooting is appreciated to figure out the issue. 

Share this post


Link to post
Share on other sites
illinimatt81

Some additional info - we are not seeing any issue when I roll back to DMS 2.1.1. The bug seems to have been introduced in 2.1.5

 

 

Share this post


Link to post
Share on other sites
Simon

DMS does not have a file /includes/class.css.php the old PageLines Framework had that file whats the site in question?

Share this post


Link to post
Share on other sites
illinimatt81

runneracademy.com

 

I did upgrade the site from Framework to DMS1 and then to DMS2. Strange that it seems to only show up and throw errors in DMS 2.1.5. I've been with you all the way through! Sounds like there is old code then. Anyway to safely get rid of it? I reverted back to DMS 2.1.1 for now.

Share this post


Link to post
Share on other sites
Simon

Well, not sure what else to suggest really...

 

You were running 2.1.5 which site in /wp-content/themes/dms/

 

You host reports an overuse from a totally different WordPress theme at /wp-content/themes/pagelines/includes/class.css.php .. 

 

Which I can userstand you still having the folder there, but not the active theme...

 

So how does downgrading DMS ( which wasnt the issue ) fix the issue for them?

 

Are they sure it isnt another user on the machine with a pagelines framework install?

Share this post


Link to post
Share on other sites
illinimatt81

I see what you are saying...the code in question is not in my runneracademy.com domain but instead in the host root. Turns out I did have a Wordpress Install on the root domain at one point and it was Framework. I went ahead and deleted all of those files from the root so hopefully whatever reason they were being accessed/called will be resolved. I do not have an active website on the host root so they were unnecessary.

 

Is there any chance there is old code in the DMS sites from Framework that needs to be cleaned up that I can dig around and find old directories? I do notice that any page that was a Framework page and had a Framework section now has custom variables in the backend.

 

Share this post


Link to post
Share on other sites
illinimatt81

Turns out deleting the defunct pagelines framework files out of the root directory seems to have cleared the issue. Who knows why DMS 2.1.5 vs 2.1.1 made any difference in an add-on domain. Simon did help me point to it being in another directory which should have been obvious to me!

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×