Jump to content

Archived

This topic is now archived and is closed to further replies.

jillginsberg

Locked out of Wordpress dashboard

Recommended Posts

jillginsberg    0
jillginsberg

I am unable to log into the Wordpress dashboard for my website. When I try, I get a page of lines saying:
Warning: Creating default object from empty value in /home/hundreds/hundredsofhundreds.com/wp-content/themes/platformpro/core/library/class.layout.php on line 159 (and line 162, etc)

I have not posted to my wordpress site in a while, but keep it reasonably updated and haven't made any changes or deleted any important files that I am aware of. Any help much appreciated!

http://www.hundredsofhundreds.com

Share this post


Link to post
Share on other sites
Simon    247
Simon

If you log into pagelines.com, under my-account you will be abole to download the latest version of PlatformPro, 1.6.1. You are using 1.2 which is years out of date.

 

The problem you are experiencing is your host upgrading the version of PHP without telling you ;) the lastest version of PlatformPro has these warnings suppressed allowing you to log in.

 

Alternatively if you don't want to update the theme and wish to keep everything as it is, just ask your host to turn off PHP error logging. It should be off in a production environment anyway.

Share this post


Link to post
Share on other sites
jillginsberg    0
jillginsberg

Simon - thank you. I am ashamed to say that I downloaded the update and have no idea what to do next. (This is what happens when a 20-something sets up your blog for you and leaves you to your own devices!) Tried to look through the wiki and forums but don't see simple instructions for updating. My host is not able to deactivate the error logging and I wash't able to figure out how to do it myself. Gosh, I sure feel dumb. Is there someplace I can find simple instructions for installing the updated version? THANK YOU.

Share this post


Link to post
Share on other sites
Simon    247
Simon

do you have a way to edit the functions.php file?

 

Upgrading such an old version would probably break more than fix issues. There is old then there is old ;)

 

If you can edit the functions.php file either via FTP or via some sort of host editor then you can just add the changes that suppress those errors.

 

Here is a link to the file to change and I have highlighted what you need to add. https://github.com/pagelines/platformpro/blob/master/functions.php#L11-L13

Share this post


Link to post
Share on other sites

  • Similar Content

    • mrmyth
      By mrmyth
      Hello:
      I have several sites on Host Gator that have been using Platform Pro. This template was great for me until recently, when after a Word Press update, all the sites just have the page heading and all the rest of the content doesn't display.
      Thanks for your help.
       
    • Houston Haynes
      By Houston Haynes+
      Hey folks - I'm trying to get right of some 'dead space' at the bottom of the page in the Material Theme. (see attached) Those two gray lines have an "Edit" button in between them when the browser has a login cookie for the site. Here I created a screenshot from a browser session that doesn't have context for my main login, so you can see that the "Edit" indicator is gone, but the bars and the space it occupies still remains. Can someone help me isolate this so I can make it *completely* disappear? Thanks.

    • b1mills
      By b1mills
      I have bought whitehousepro themes, and these themes has been uploaded, but at the moment in the reviews are not visible. please help step by step to install these themes, thanks.
    • dadomagico
      By dadomagico
      Hi,in my site http://www.mobiliariofarmacia.es/
      at the top appairs this error:
      /** Outputs the WordPress header. */ require_once(ABSPATH . 'wp-head.php');
      How can i resolve?
      I have updated the theme and also wordpress ma doesn't work
      Please Help me!
    • troppoimages
      By troppoimages
      I've encountered the WSOD on my account turmericforanimals.com & according to BlueHost its due to an error due to result of a broken/corrupt theme or plugin
       
      I have been using DMS with pinspro plugin
       
      I tried all their troubleshooting solutions BUT nothing has worked so I'm seeing if you can clear it up.
       
      I followed their guide to
       
      They say that: - "its not hacker related it has something to do with the errors in the code thats why when I checked the error logs it says: syntax error, unexpected '<' in /home3/turmeri6/public_html/wp-content/themes/pinspro/header.php on line 9"
       
       
      Are you able to help with this OR do I need to go back to BlueHost??
×