Jump to content

Archived

This topic is now archived and is closed to further replies.

jmad

RevSlider and Mobile Navigation - not playing nice

Recommended Posts

jmad+    80
jmad

I've tried both Navbar and Navi in full width and am getting the same issue.  I haven't tested on other mobile devices other than iPhone (a few different versions).

 

You can see the issue here msdbuild.flywheelsites.com (flywheel, furtive-music are needed to view site).

 

When the mobile Nav is open and Rev slider progresses to the next slide, the slide becomes taller, if you click in Search and then click "done" the slider doesn't shrink (which means text if centered is being cutoff) and it won't progress to the next slide.  If you don't click in the search box but just back on the page then the slider doesn't shrink but will still progress to the next slide.   Either can be fixed by manually sliding but I it seems this would need corrected.  

 

I had trouble pin pointing when the slide wouldn't start backup but regardless this doesn't seem like something that should be happening.

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

I can't see it, therefore I am likely not following your instructions correctly, would it be possible to record the issue please. Also, can you recreate it using a RevSlider without any custom HTML i.e. just the options used. If not then the likely cause is your HTML you have used via the extra slider options.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad+    80
jmad

Here you go.  I don't have any custom CSS in the site no any extra captions in the slider.  It's all just the basic slider options.  

 

On desktop, where I was recording, I couldn't get the slider to lock up but on mobile it does.  Seems like RevSlider should pause while menu is open and problem would be resolved.

 

http://screencast.com/t/ra0roauJ

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, I am not able to recreate the issue you have with your the text being positioned slightly like you have on your video, regardless of what I do. However, I do experience an annoyance where when I close the mobile menu, my Chrome browser (mobile refreshes upon the closing of the mobile menu). So I have reported this. But I am unable see recreate your other issue.

Also, the RevSlider should continue when the mobile menu is open, not sure why you think it should stop ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad+    80
jmad

What do you mean by the "the text being positioned slightly".  I'm using Safari to view the site in the video and it happens consistently when browser is scaled to mobile and on mobile device itself.

 

I was just thinking if Rev Slider stopped when the menu was a open then it wouldn't expand off the page and occasionally get stuck. 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I've reported this to our tracker, along with your video.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad+    80
jmad

Any update on this issue?  This is a big one as it makes Rev Slider basically unsatisfactory for use on client sites.  

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

We've looked at it and we are not able to recreate it. Are you using the extra slides options to add your text or just the standard fields? Also, does this happen when viewed on a mobile device as I can't tell on the video if this your browser resized or a mobile device.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad+    80
jmad

No I'm not using extra slides options just the standard fields and yes it happens on mobile (iphones and ipads).  Look at scramblers-schemers.flywheelsites.com (flywheel and light-plant will be the login and pass). 

 

I can recreate the issue with a clean install of DMS on a test site by adding rev slider, 3 photos in the dimensions mentioned in DMS editor and nothing else in the site.  That is what I did in the test build on the demo I provided.  It really irritates me that it takes the DMS team a month to say that they can't recreate an issue.  

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Is this what you're referring to - http://quick.as/a9rgigl9

Also, not sure what you mean by search then click done done where is done ? 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad+    80
jmad

Yes.  That is the issue in the video you provided is the exact one that was happening in the video I provided already in this thread.  Currently I have the slider set to fill the window.  When I don't then clicking on the menu increases the size of the slider. 

 

"Done" appears as part of the ios keyboard because when you tap on the menu the cursor automatically defaults to the search area.  Only if you sort of hold down the mobile icon does the cursor not go to the search area.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Finally, I was able to recreate it. I have updated the ticket with my video and steps on how to recreate it. Thanks for your patience, it was a pain to recreate it, as it wasn't happening at first, maybe I wasn't waiting long enough with the mobile menu open.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • decmech
      By decmech+
      Hey Guys,
      Having some issues with the dropdowns for the Navi in DMS. For some reason I can't have any more than 2 levels in the dropdown. The cursor is hovering over RPAS Training (and the arrow to indicate more is visible) but no matter what browsers, it never shows up. Also inspecting the HTML shows that the additional fields are not there.
      I have inspected the PHP and cannot see anything that is limiting the number of levels. Any assistance to get the additional levels showing would be great.

    • bnapoli
      By bnapoli+
      http://731.34b.myftpupload.com/ this website is using the NavPro navigation in Platform 5. It has a lot of menu items, so it breaks to two lines when the window is sized down. What is the media query to make the navigation either a) switch to "mobile mode" at a higher width, or b ) expand the nav into two lines. Thanks
    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • nadielp
      By nadielp+
      Hi Everyone,
      I am trying to get a single navigation item to center. I am using a scroll menu in the navigation component of Impulse. I would like to have the item in the center of the page but it defaults right. I tried setting the item to center a few different ways and nothing is working. I added {
        display: inline-block;
        position: relative;
        text-align: center;
      }
      but that didn't work...any help would be appreciated. Site is at http://vetpaw.org/new
       
      Thanks!
      Daniel
    • yemoonyah
      By yemoonyah+
      I just installed and added the Flipper section to my home page and it makes my navigation/menu bar items disappear.
      They do show up again when scrolling down and everything seems normal on the other pages.
      http://yemoonyah.com
      Thanks.
       
×