Jump to content

Archived

This topic is now archived and is closed to further replies.

JimP

DMS Editor not loading on blog page

Recommended Posts

JimP

Hi there - I have a problem with getting the DMS editor to load on http://swiftupgrade.wpengine.com/blog  (No problems with the editor loading on the home / root page,  http://swiftupgrade.com)

 

I disabled all plugins, and tried to see if that would help load the editor on the blog page....no change. 

 

I read through the documentation and forums here; http://docs.pagelines.com/support-troubleshooting/common-issues

 

This lead me to some errors, shown in this screenshot.  http://monosnap.com/image/lotjvK1sCXkZgKJX9QE4cdbrIlKkGX.png 

 

So wondering if anyone can point me in the right direction to fix the errors. any help is greatly appreciated. - JP

 

It seems this is the error message in the console view now since I upgraded DMS; 

Resource interpreted as Stylesheet but transferred with MIME type text/html: "http://swiftupgrade.com/blog?pagedraft=1". blog:30
Uncaught SyntaxError: Unexpected token < blog:378
event.returnValue is deprecated. Please use the standard event.preventDefault() instead. jquery.js?ver=1.10.2:4

This was the error previously;

Uncaught SyntaxError: Unexpected token < blog:377
event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
3
Uncaught TypeError: Cannot read property 'scrollHeight' of undefined pl.toolbox.js?ver=bb82a2:257
(anonymous function) pl.toolbox.js?ver=bb82a2:257
x.event.dispatch jquery.js?ver=1.10.2:4
handler utils.mousewheel.js?ver=bb82a2:81

Share this post


Link to post
Share on other sites
Simon

JimP Looks like you have a PHP error. Look at the view-source of the page in your browser, scroll down and see if the page stops before </html>

Share this post


Link to post
Share on other sites
JimP

Hi Simon, I looked at the view source page and here's what it looks like; Do you have any further advice? I went and added these lines of code to wp-config file too.

 

define( 'SCRIPT_DEBUG', true );
 
define( 'WP_DEBUG_LOG', true );
<a class="screen-reader-shortcut" href="http://swiftupgrade.wpengine.com/wp-login.php?action=logout&#038;_wpnonce=9475673e35">Log Out</a>
					</div>

		</body>
</html>

Share this post


Link to post
Share on other sites
JimP

Here's the DMS debugging information too;

 

DMS Debug Info

WordPress Version
3.9.1

WordPress Debug
Disabled

Multisite Enabled
No

Current Role
Administrator

Framework Path
/nas/wp/www/cluster-2262/swiftupgrade/wp-content/themes/dms/dms

Framework URI
http://swiftupgrade.wpengine.com/wp-content/themes/dms/dms

Framework Version
2.1.4

PHP Version
5.3

WP_DEBUG
No

WP memory limit
40 MB

WP MAX memory limit
256 MB

PHP memory limit
256 MB

Mysql version
5.5.35

WP Max Upload Size
50 MB

PHP POST Max Size
100 MB

PHP Max Execution Time
3600s

PHP type
Apache2handler

WebServer software
Apache

PHP User
Posix functions are disabled on this host. Not necessarily a problem, but if the user needs FTP/SFTP to install plugins/themes then creating CSS files might be an issue.

OS
Linux

Installed Plugins
accordions/accordions.php
dms-plugin-pro/dms-plugin-pro.php
pagelines-updater/pagelines-updater.php
post-types-order/post-types-order.php
super-simple-google-analytics/SuperSimpleGoogleAnalytics.php
wordpress-seo/wp-seo.php

Share this post


Link to post
Share on other sites
Danny

Please keep all plugins disabled.

 

Also, when you say you you viewed the page source and here is what it looks like what do you mean ?

 

Also, have you enabled WP_DEBUG i.e. set it to true instead of false ? When this active are there are any errors printed ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JimP

Hello Danny;

 

1. I did disable all plugins; and still had no ability to load DMS editor on any pages but the root /home page. I re-enabled plugins, as the site doesn't function properly without them. 

2. when I say I viewed the source page code, Simon_P said to check:  

----> Looks like you have a PHP error. Look at the view-source of the page in your browser, scroll down and see if the page stops before </html>

 

So, my reply was to show the location of the </html> tag at the end of the page.

 

3. I have added; define( 'WP_DEBUG_LOG', true ); to the wp-config file. 

 

4. I don't see any errors printed, but I also don't know exactly where to look to see any printed errors. 

 

thanks in advance for any and all help  - Jim

 

 

 

Share this post


Link to post
Share on other sites
JimP

Here are the error messages from the console; 

Resource interpreted as Stylesheet but transferred with MIME type text/html: "http://swiftupgrade.com/blog?pagedraft=1". blog:31
JQMIGRATE: Logging is active jquery-migrate.js?ver=1.2.1:21
Uncaught SyntaxError: Unexpected token < blog:279
JQMIGRATE: jQuery.event.handle is undocumented and deprecated jquery-migrate.js?ver=1.2.1:41
console.trace() jquery-migrate.js?ver=1.2.1:43
migrateWarn jquery-migrate.js?ver=1.2.1:43
Object.defineProperty.get jquery-migrate.js?ver=1.2.1:58
(anonymous function) utils.isotope.min.js?ver=7e544a:10
(anonymous function) utils.isotope.min.js?ver=7e544a:10
{"post":{"action":"pl_editor_actions","mode":"fast_save","run":"map","pageID":"15","typeID":"70000006","log":"true","confirm":"false","confirmText":"Are you sure?","savingText":"Saving.","refresh":"false","refreshText":"Refreshing page...","refreshArgs":"false","toolboxOpen":"false","beforeSend":"","postSuccess":"undefined","load":"false","onFalse":"","store":{"fixed":{"map":{"0":{"name":"","class":"","id":"naviu06b4b","object":"PLNavi","sid":"navi","clone":"u06b4b"}}},"header":{"map":{"0":{"name":"","class":"","id":"pl_areau06b98","object":"PLSectionArea","sid":"pl_area","clone":"u06b98"}}},"template":{"map":{"0":{"name":"","class":"","id":"pl_areauc99e2","object":"PLSectionArea","sid":"pl_area","clone":"uc99e2","content":{"0":{"object":"PageLinesPostLoop","clone":"uc9ba6","sid":"postloop","span":"10","offset":"1","newrow":"false"}}}}},"footer":{"map":{"0":{"name":"","class":"","id":"pl_areau06e7d","object":"PLSectionArea","sid":"pl_area","clone":"u06e7d","content":{"0":{"object":"PLSocialinks","clone":"u0702e","sid":"socialinks","span":"12","offset":"0","newrow":"false"}}}}}},"templateMode":"local","location":"start","storeMap":"true"},"dataAmount":2438,"config":{"fixed":{"map":{"0":{"name":"","class":"","id":"naviu06b4b","object":"PLNavi","sid":"navi","clone":"u06b4b"}}},"header":{"map":{"0":{"name":"","class":"","id":"pl_areau06b98","object":"PLSectionArea","sid":"pl_area","clone":"u06b98"}}},"template":{"map":{"0":{"name":"","class":"","id":"pl_areauc99e2","object":"PLSectionArea","sid":"pl_area","clone":"uc99e2","content":{"0":{"object":"PageLinesPostLoop","clone":"uc9ba6","sid":"postloop","span":"10","offset":"1","newrow":"false"}}}}},"footer":{"map":{"0":{"name":"","class":"","id":"pl_areau06e7d","object":"PLSectionArea","sid":"pl_area","clone":"u06e7d","content":{"0":{"object":"PLSocialinks","clone":"u0702e","sid":"socialinks","span":"12","offset":"0","newrow":"false"}}}}}},"load":"false","state":{"local":"local"}} pl.helpers.js?ver=7e544a:14
Object {post: Object, dataAmount: 2438, config: Object, load: "false", state: Object}
config: Object
dataAmount: 2438
load: "false"
post: Object
action: "pl_editor_actions"
beforeSend: ""
confirm: "false"
confirmText: "Are you sure?"
load: "false"
location: "start"
log: "true"
mode: "fast_save"
onFalse: ""
pageID: "15"
postSuccess: "undefined"
refresh: "false"
refreshArgs: "false"
refreshText: "Refreshing page..."
run: "map"
savingText: "Saving."
store: Object
storeMap: "true"
templateMode: "local"
toolboxOpen: "false"
typeID: "70000006"
__proto__: Object
state: Object
local: "local"
__proto__: Object
__proto__: Object
__defineGetter__: function __defineGetter__() { [native code] }
__defineSetter__: function __defineSetter__() { [native code] }
__lookupGetter__: function __lookupGetter__() { [native code] }
__lookupSetter__: function __lookupSetter__() { [native code] }
constructor: function Object() { [native code] }
hasOwnProperty: function hasOwnProperty() { [native code] }
isPrototypeOf: function isPrototypeOf() { [native code] }
propertyIsEnumerable: function propertyIsEnumerable() { [native code] }
toLocaleString: function toLocaleString() { [native code] }
toString: function toString() { [native code] }
valueOf: function valueOf() { [native code] }
get __proto__: function __proto__() { [native code] }
set __proto__: function __proto__() { [native code] }
 pl.helpers.js?ver=7e544a:14
event.returnValue is deprecated. Please use the standard event.preventDefault() instead. 

Share this post


Link to post
Share on other sites
Danny

Please set the value to true on WP_DEBUG in your wp-config.php file. We are not referring to the WP_DEBUG_LOG, but just WP_DEBUG, this is in your wp-config.php file by default and has a value of false, replace false with true, save the changes and then visit your page again where you have a blank screen. With WP_DEBUG enabled, there will most likely be errors printed.

 

http://codex.wordpress.org/Debugging_in_WordPress


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Tom
      By Tom
      Hi, I desperatly need some help fixing the DMS editor. It's not loading at all en gets stuck at 'Oops there may be an issue loading.'
      I'm able to find this two warnings in chrome:
       
      www.studiekeuzemaken.nl/:4607 Uncaught SyntaxError: Invalid or unexpected token
      pl.editor.js:740 Uncaught TypeError: Cannot read property 'lang' of undefined
          at Object.reloadConfig (pl.editor.js:740)
          at Object.startUp (pl.editor.js:72)
          at HTMLDocument.<anonymous> (pl.editor.js:10)
          at i (jquery.js:2)
          at Object.fireWith [as resolveWith] (jquery.js:2)
          at Function.ready (jquery.js:2)
          at HTMLDocument.K (jquery.js:2)
       
      When I dug into the first warning a little deeper (line 4607)I found out that there is a typo in a css that's causing the SyntaxError. Because the css is placed within a textbox and the editor is not loading I'm not able to fix this.

      What can I do?

      Please help!

      - Tom
       
       
       
    • werdnags
      By werdnags+
      Hi Folk,
      Can anyone help me please.  On a page on my site I placed an 'embed section' and inserted code from the Eviivo Booking system that seems to call scripts from their site.  After doing the PL5 editors will not load so I can't edit anything.  Is there anyway of disabling the section so I don;t have to rebuild the page?
      Thanks.
    • chamois_blanc
      By chamois_blanc+
      Please see screenshot. I think it should be self-explanatory.

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • Peter Esslemont
      By Peter Esslemont+
      Hi,
      When using the editor I am getting duplicate wordpress toolbars and an a nice error to go with it...
      I have them stack 4 high at one point.  Goes away with a refresh then re-appears.
      very odd.

       
       

×