Jump to content

Archived

This topic is now archived and is closed to further replies.

MobileParity

Shortcodes not working

Recommended Posts

MobileParity+    0
MobileParity

I have been trying to use several shortcodes (google map, accordion) in media boxes however the shortcodes are only displaying the raw text and not the correct shortcode output.

  • I have disabled all plugins and purged the cache from the site. 
  • Removed all spaces from shortcode syntax
  • Added shortcode to media box text/html area.

I am using DMS2 and Wordpress is updated to the most recent version. I have inlcluded a screenshot below>

http://screencast.com/t/FYLgWXon0q

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

Shortcodes aren't text or HTML. Therefore, if you want a shortcode to work you either need to place the shortcode in the the Page or Post content area via the WordPress Post/Page editor or use the PL NextBox section which supports shortcodes. The NextBox section is a club section only.

If you do not wish to join the club to gain the NextBox section, you can try adding the shortcode the MediaBox title field.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

Hello Danny,

 

I have also tried adding shortcodes to the WP content area and it still does not work. Neither does adding the shortcode to the mediabox section as you mentioned. Is there no other way?

Share this post


Link to post
Share on other sites
batman    389
batman

Hi MobileParity

Very strange....

Please, you can add this code to see this work in your site

 

[googlemap width="600" height="300" address="San Francisco, CA"]

 

This work fine to me in the MediaBox title field.

 


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

Hello Batman,

 

This still does not work. Could it be an issue with my host? I am also using a dms 2 child theme created from Orbisius Child Theme Creator however this has not been in a issue in the past.

 

Regards,

 

AG

Share this post


Link to post
Share on other sites
batman    389
batman

Hi AG

I use for this a Danny´s Child Theme, this works fine to me, perhaps you can give a try

https://github.com/Dannyholt/skeleton


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

Unfortunately the shortcodes are still not working with the Skeleton Child Theme. Is there a Pagelines plugin that must be active for shortcodes to work? The shortcode for Contact Form 7 works fine once the plugin is active. However it appears to be the Pagelines specific shortcodes that are not working.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

If shortcodes aren't working then there is definitely something wrong with your site, this could be related to plugins you have installed. As I have just added the following shortcode to a MediaBox and it is working without any issue.

 

[pl_button type="primary" link="" target="blank"]Primary[/pl_button]

 

https://cloudup.com/c3xC2DGNujU


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

I figured there is something wrong with my site. My best guess is the culprit must be my host. I have done all of the basic trouble shooting so I was hoping to get a bit more support for other common issues that reside with a shared host. As soon as I hear back from my Pagelines contact I will be upgrading to Pro De Club and hopefully I can get support that way.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

We have provided the best support we can, the issue is we are unable to recreate the issue. Therefore, the likely cause of the issue is either plugin related or related to your host.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon    247
Simon

We cant fix things with just screenshots.

 

This thread is posted in the free version forum, are you using the free version?

 

Whats the URL to the page with the issue?

 

Exactly where are you putting the shortcode text? (screenshot this)

 

There is no conceivable way a host can make shortcodes just not work, its impossible.

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

@Danny@Simon_P

I understand the best support has been provided with the information I have provided. I am not dissatisfied with the level of support and I also understand you "cant fix things with just screenshots" (this comment was not needed). I did not know what information was needed for someone on this forum to look deeper into my issue or the extent of support that is provided. As I have stated above I disabled all plugins and achieved the same result. However regarding the host it seems you both have differing opinions as to if a host can negatively effect the short codes. I am currently using the Free Version and will soon be using the Club Version. I would absolutely appreciate if someone could provide constructive feedback as to any solutions. I currently have a "Coming Soon Page" which i will disable and enable debug mode on the site located here:http://bar-gfitness.com/

Again, only respond if you are willing to provide constructive and useful feedback sans any unneeded sarcasm. I appreciate all the feedback and assistance. Let me know if there is anything else I should be doing to assist in the resolution of my issue.

 

Cheers,

 

AG

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

I also just noticed the site does not display correctly in IE. So any help in this area would also be greatly appreciated.

 

Cheers,

 

AG

Share this post


Link to post
Share on other sites
Simon    247
Simon

So what shortcode are you trying to use and where exactly are you putting it?

Share this post


Link to post
Share on other sites
Simon    247
Simon

The free version has very few shortcodes bundled with it as its against the wordpress theme guidelines.

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

Shortcodes I am trying to use:

  • Accordion
  • Google Map
  • Tabs

Places I have tried to use them:

  • WP Content Area
  • Media Box (in the Title Section)

 

Share this post


Link to post
Share on other sites
Simon    247
Simon

Those shortcodes are not in the free version im afraid.

 

Sorry for any confusion caused in the rest of this thread.

 

We simply cant bundle content shortcodes in the free version, they dont allow it.

 

The regular version has all the shortcodes included.

  • Like 1

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

Understood. I really appreciate the help.

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      We're often working with ACF (https://www.advancedcustomfields.com/) that's great for user experience in the backend, 'cause we don't want out clients to be in the editor to much.
      So we want to be able to use shortcodes in the editor fields, regardless of section, THIS WOULD BE SO GREAT. Is there a way to fix this, it should open up som much more functionality.
      In ACF, the shortcode is for example: 
      [acf field="field_name"] ...for example, I want to att field_names value to display in a section, i understand I can make it in embed and so, but I want it in titles and options, the whole range.
      I know I can build my own sections, that we've done, but it's not very effective, and thats what PL5 is about.
      Any ideas on this, can Pagelines take this in the core? I guessing there are more than just ACF out there who can use this.

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • micstepl
      By micstepl+
      Pagelines seems to "disallow" the (a) usage and/or (display) of shortcodes.
      Specifically I need shortcodes in "description" of "tag/catagory" in order to display images/fontawsome, before a category.
      Please can you provide a fix for me to allow. 
×