Jump to content

Archived

This topic is now archived and is closed to further replies.

jamesmaccer

missing scroll bar - Chrome only

Recommended Posts

jamesmaccer

Hi, 

 

I run two sites through pagelines. Firstly www.makemetv.com - no issues with this one. Secondly www.fmp-ir.co.uk  - problem is with this one. 

 

With this site (click here to see)  the vertical scroll bar on chrome dissapears. you can still scroll using the middle roller on the mouse, but basically anyone with a laptop and no external mouse will not be able to navigate the site. 

 

This only happens in Chrome (not firefox etc) and only on two pages of the site (home page, 'five minute pitch tv' page). 

 

This is a recent development. Any ideas?

 

Cheers

 

James 

Share this post


Link to post
Share on other sites
jamesmaccer

I have just disabled all plugins & still happening as well. 

 

In summary - only happening on chrome. Plugins not the cause. only happens on two pages of the website. 

Share this post


Link to post
Share on other sites
Danny

Hi James,

 

I have just viewed your website in Chrome for OSX and the scrollbar is visible. Have you resolve this issue ?

 

http://quick.as/DZxBUy1z


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jamesmaccer

I'm using chrome on PC & not resolved. If I take a screen shot, the bar shows, but it is not there when you are actually using the site. 

 

The weird thing is that it only happens on two pages??

 

I'm trying to think what i've coded on to those pages which I haven't on the other pages & completely dumfounded!

Share this post


Link to post
Share on other sites
jamesmaccer

Hi Danny, 

 

I've worked out what is causing it, but could use your brain to help resolve. 

 

I recently added the 'hidden-tablet' as some pictures look rubbish in portrait view on an ipad. However this is causing the side-bar to dissapear in my version of google. If I get rid of the hidden tablet setting, the scroll bar comes back. 

 

I did quite a lot of reading on this & followed your guidelines, but what your documentation suggested didn't quite work (with hidden-phone).  To explain - for 'hidden tablet' I didn't have to put anything in the CSS - I just typed 'hidden-tablet' into the media box / text box & voila. Simiar for 'visible tablet. 

 

However for 'hidden-phone', I had to add some CSS, as it didn't work initially. 

 

@media (max-width: 767px) {
  .hidden-desktop {
    display: inherit !important;
  }
  .visible-desktop {
    display: none !important;
  }
  .visible-phone {
    display: inherit !important;
  }
  .hidden-phone {
    display: none !important;
  }
}
 
The site has always had this 'hidden-phone' setting & it's never caused a problem. The problem has been caused by the addition of 'hidden-tablet'. Hopefully you'll follow what i've done. For instance, the first picture you see on the homepage (the image of a play button surrounded by stick men). At all widths, the column has 'hidden-mobile', and the media box contains 'hidden-tablet'. Then when getting to tablet width i've reloaded the image into a new media box (with a slightly different placing) and put in 'visible-tablet'.
 
I tried lots of other more obvious variations, but none seemed to work. This functionality works very well - however it's getting rid of the scroller in Chrome! 
 
I hope that all makes sense. 

Share this post


Link to post
Share on other sites
Danny

Just use the options that come with all sections when you have DMS Pro Tools active. Also, are you saying that when you remove your custom code that you posted above, the scrollbar in your Windows version of Chrome reappears ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jamesmaccer

Hi Danny,

 

I presume your talking about the boxes within the text box / media player etc -  'hide for mobile users' . Problem with that is it's impossible to design the site properly, as you can still see the space for the images. Also, there is no option for a ipad portrait only layout (circa 768 px)

 

Yes, the problem is solved if I remove any images which I have applied this  'tablet only'. However, I want the tablet only option. 

Share this post


Link to post
Share on other sites
jamesmaccer

Solved it. 

 

added .visible-desktop to the whole section area, then another section area with .visible-tablet and another section area with .visible-phone

Share this post


Link to post
Share on other sites

×