Jump to content

Archived

This topic is now archived and is closed to further replies.

Dave2

The Old Not Saving Changes Dance

Recommended Posts

Dave2    1
Dave2

I really enjoy the power of PageLines DMS. The speed and ease of editing and redesigning a site is fantastic.

 

What I do not enjoy is the difficulty I experience every time I want to make changes. I see many posts in the forums about edits/changes not being saved. The response is always the same: turn off all plugins, clear caches, and disable all chrome extensions. 

 

Is this really the way to treat such s recurring theme in the forums?

 

Worse, for me at least, is it seems the magic dance of what I need to do to get DMS saving my edits changes every time I go to make changes. So now I spend an inordinate amount of time trying different combinations of things to get the editing ability to work. 

 

This, in my view, nullifies the promise of DMS--the ability to make changes on the fly on a live website. While this may work with a few sites, I suspect that there are many users, based on the number of posts about DMS not saving work, that suffer from this issue. 

 

I mean, if I need to put my website into an unusable state just so I can make some edits to the front end via PageLines DMS what have I gained? 

 

I implore you to find a solution to this issue. Return errors so that we can begin to help you guys fix this. It is bad enough that the work is not saved, but there are not even any errors being reported that I can find!!!

 

I understand the complexity of what you have done, and I applaud your work. But I find a fatigue setting in on my side where I just do not know if the continued chasing my tail to get my work to save is worth continued use of this framework.

Share this post


Link to post
Share on other sites
Simon    247
Simon

We'd of course love to fix this 'error', but it isnt easy to fix something we cannot replicate.

 

We dont get the error locally.

We dont get the error on any of our private sites, I have about 3 VPS sites and several servers. The mods all have sites too, no errors.

We have the themes preview site, another VPS, no errors.

We have the free to signup demo, that has 1000's of sites and users, no errors there either.

 

If you want to help us, then provide us with a site that has this problem, and clear steps to reproduce the issue so we can attempt to find the issue.

 

We cant reproduce an issue that we don't have, if you see the problem.

 

I know its a pain, and every time we have asked for help we seem to always end up with the following:

'..it sometimes doesn't save and now I cant reproduce it either...'

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Simon:

 

Fair enough. But as I said this seems to be a recurring issue on the boards. 

 

You can, I hope, appreciate the risk of handing out the access to a live site? If there was a way to grant you all access to a site that did not require access to the backend it would be easier to allow you all in. But as it is, everytime I let someone into the backend it requires, for security reasons, a reset of numerous other connected services. This is not a statement of mistrust; it is just SOP for us. So it is a royal pain to grant folks admin access to the live site. 

 

If you have a way to access the site that does not require admin access I would love to work with your team. 

 

Is there a happy medium we can find?

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Here is a short video of 1 minute that shows the edit being made to change the text in a price box. You will notice that the update never happens. Debug mode was on while this change was attempted. http://screencast.com/t/2KpGE3BY6

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Could we have a link to your site please? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok great thank you for this.

 

 i cannot access your debug page at http://winetastingtrends.com/?pldebug=1 

 

Could you please list the plugins you have active on your site? or provide a screenshot if this is easier. whichever works best for you. 

 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Martin:

 

How do I send you the file privately? I do not want this information posted publicly.

 

Dave

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Of course you can - can you send to hello @ PageLines dot com and i will pick it up from the Helpdesk team - Thank you very much 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

The file is on its way. I put your name in the subject line.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Thank you Dave - as soon as it comes in i will take a look for you and update you here. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok so you are using Cloudflare as your host. Could you ask them to disable caching on your server. if they can do this then try making the changes again and they should stick this time. What you are most likely seeing is a cached version of the page. Making changes to cached versions of pages will likely not work and lead to these problems. 

 

in short you are not changing the actual page but a cached version of the page. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Martin:

 

Cloudflare is not the host, but I am using them for cache and the other benefits they provide. I can turn off the cache, and purge the cache. I can also turn on development mode--I will give them a try and report back. 

 

Just so you know when those changes were attempted Cloudflare was in development mode. 

 

Dave

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok thanks. Try this without cloudflare and let us know how you get on. Make sure you correctly clear your cache however the documentation advises . 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

No joy.

 

I tried the following:

- Turned on Development mode. This mode in CloudFlare is supposed to bypass all cached content. Result: Changes not saved.

- Turned off caching in Chrome via Developers Tools and left CloudFlare in development mode. I am also conducting the test in incognito mode in Chrome. Result: Changes not saved.

- I purged the web page from the cache in CloudFlare,  left local caching disabled in Chrome, stayed in incognito mode. Result: Changes not saved.

- I turned off CloudFlare, purged local cache, left local caching disabled in Chrome, stayed in incognito mode. Result: Changes not saved.

- I told CloudFlare to bypass all requests to the site completely, purged local cache, left local caching disabled in Chrome, stayed in incognito mode. Result: Changes not saved.

 

So I suspect this is not the cause of not saving changes. 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Could you completely clear the cloudflare cache and deactivate the plugin. 

 

Also, could you disable all non-PageLines plugins and see if this resolves the issue. If there is any progress with this re-enable them one by one to see which is causing the issue. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Martin:

 

I did the full cache flush of Cloudflare with no change. 

 

The turning off and on plugins I will do at night when the site is less likely to be impacted--after all this a site in production and, per my rant last night, toggling plugins to that one can edit the front page voids the benefit of PageLines DMS. Please do not take this the wrong way--I am willing to help trouble shot this as it will help all of us that are adopting your technology. It will just take longer as I cannot put the website into an unusable state during prime business hours.

 

My biggest issue is this. There are no errors that I can find anywhere. So DMS fully thinks it was successful in saving the edits. If we had errors we would at least have a starting point.

 

In the past, I have just turned off all plugins made my edits and reactivated all plugins. But as I said, this is not really an acceptable approach. Especially when a site is serving an international audience.

 

Will post more once I run tests tonight.

 

Dave

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Please let me assure you we understand the problems with turning things off and on but we have to rule out the issues. 

 

The vast majority of issues along these lines are related to caching. DMS doesn't know what it is doing wrong as it isn't doing anything wrong. WordPress is serving the pages to DMS (crude example and i am sure simon can give you a much much more detailed explanation of this) and DMS is doing as it should. The pages being presented to DMS for editing appear to not be the actual pages. 

 

The other thing about caching is it should not be in place at all until the site is totally finished and launched. If there are any changes to be made the caching plugins should be correctly cleared and deactivated, 

 

Also (and again please let me assure you this is in no way a criticism of your companies SOP) it is difficult to see what is going on without access to the debug ourselves or at a final resort, being able to visit the backend of your site (not that this is a method we jump to in order to fix things) . In itself, not being able to access the debug screen is symptomatic of caching issues. 

 

Please let us know how you get on and if we can help with anything further. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Martin:

 

A few things to consider.

  • Many companies have SOPs that limit access by non-employees to the backend. One way to deal with this would be to allow a special role to be created that you used to enable DMS. This would allow you to see the front end and still protect the backend.
  • You know that just like code, the last edit/fix to a website will be discovered the day it is taken out of service. Websites are never done. :-)

Have a great day! I do appreciate your help on this.

 

Dave

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

the other question you need to ask is do you need the caching functionality? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

Martin:

 

An excellent question and one that is under review. :-)

 

Dave

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

i find you may not actually need it most times. It is much better overall that the site is well optimized and simon wrote a great post about this. Much better for visitors, yourselves and for SEO if your site is better optimized. 

 

http://forum.pagelines.com/topic/25369-the-quest-for-speed/


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Dave2    1
Dave2

And the answer is....

 

Drum Roll Please

 

WordPress HTTPS plugin is causing the problem. When it is active I am not able to save edits done via DMS. When I deactivate it, I am able to save the edits once again.

 

So now we know.

 

Dave

  • Like 1

Share this post


Link to post
Share on other sites
Simon    247
Simon
Is it forcing admin as https?


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
MrFent+    28
MrFent

I've had the same issue with the HTTPS plugin when forcing admin as https. It does the same thing as having define('FORCE_SSL_ADMIN', true); in wp-config.php.

 

The work arounds:

 

The DMS options will save if you are https on the front end page you are working on. 

 

The other option is to add

 

add_action('wp_ajax_nopriv_pl_editor_actions', 'pl_editor_actions');

 

to your child theme's functions.php, however this is not a complete solution. While it does allow some options to save, there are other things you can't do like upload an image using the DMS image uploader. 

 

 

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×