Jump to content

Archived

This topic is now archived and is closed to further replies.

MissT

Secondary Menu Not being activated on Mobiles

Recommended Posts

MissT+    4
MissT

Hi there,

 

I'm using DMS 2.1.1 with a child theme. And WP 3.9.1. All plugins except DMS tools and Updater deactivated.

 

The Secondary Menu isn't appearing when the site is viewed on mobiles - the normal main menu - which is has too many options for mobiles is still appearing.

 

If my understanding is correct the menu I've selected for the secondary menu in the site navigation set up should appear on mobiles.

 

I can provide the URL via email.

 

Many thanks in advance.

Share this post


Link to post
Share on other sites
MissT+    4
MissT

URL just emailed to hello@pagelines :)

Share this post


Link to post
Share on other sites
onlineprofiler    22
onlineprofiler

hello MissT

just double check if you activated the secondary menue in the front-end editor under the tab Side Settings / Layout & Nav. At the very right side you will find the Default Navigation Setup. here you need to activate the secondary navigation menu. Just choose the right one via dropdown.

Hope I could help.

 

Nice greetings, Sii


onlineprofiler.png

I am ^sii from @onlineprofiler, digital media specialist, love web design, development, WordPress, PageLines and lots more...
http://www.onlineprofiler.co

Share this post


Link to post
Share on other sites
MissT+    4
MissT

Yes that is all set up but isn't working :)

Share this post


Link to post
Share on other sites
MissT+    4
MissT

To clarify...the menu I have selected as the secondary menu only has the following options with no sub levels...

Home
Store
Our Story
Testimonials
FAQ's
Newsroom
Contact

 

The normal menu is much larger with sub levels and pretty unusable on mobiles.

 

Thanks in advance.

 

 

 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hi this topic had been marked as resolved by yourself. Is this still a problem? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
MissT+    4
MissT

I swapped over the menu's that were selected for the Primary and Secondary menu settings and it now works as I wanted it to.

 

It may be just me but the help info by the settings themselves and the notes in the docs is a bit confusing. Or maybe I was remembering how it worked in previous versions but I would have expected Primary menu to be for the main menu and Secondary to be the fallback for mobiles - however it seems to be the other way round.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok thanks for letting us know. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

  • Similar Content

    • MissT
      By MissT+
      Is there a way to get the mobile menu to close when you click a menu item that is for an anchor link with the same page?
      Currently on mobiles and ipad the black mobile menu still covers a third or the screen after you have clicked a menu item (that is linking to an anchor link) and it has scrolled to the link / section within the current page. You have to physically click within the page / away from the mobile menu to get the menu and it's black background to disappear.
      Many thanks in advance.
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • floydwebb
      By floydwebb+
      I can't find the mobile menu feature. Please let me know how to find it. 
    • flourishdesignstudio
      By flourishdesignstudio
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
×