Jump to content

Archived

This topic is now archived and is closed to further replies.

josh1178

Custom Sections - Drag thumb to page not working

Recommended Posts

josh1178

Hi there,

 

I made my first sections! Yay. Only problem is that Drag Thumb and Close aren't working. Is there something special I need to do to get these to work? There is nothing in the documentation online about Drag Thumb or Close (or custom pics for that matter).  It works if I drag from the main section tool box, but if I click on the section and go in a level to where it shows the section description, nothing in there is draggable. I click where it says 'Close' for example and nothing happen.s

 

I made a simple section to return the Woo Commerce Product Tabs as sections. I will post the all of them once I get them all fixed. 

<?php
/*
    Section: TT - Show Woo Description Tab   
    Author: JDH
    Author URI: 
    Description: Shows the Woo Commerce Product Description Tab Content 
    Class Name: ShowWooDescription
    Filter: component
    Loading: format
*/

class ShowWooDescription extends PageLinesSection {
      function section_template(){
     ?>
          
             <div class="" style="text-align:left;">
             <?php
             global $woocommerce, $post;
             
             $heading = esc_html( apply_filters( 'woocommerce_product_description_heading', __( 'Product Description', 'woocommerce' ) ) );
             ?>
             
             <h2><?php echo $heading; ?></h2>
             
             <?php the_content(); ?>
                     </div>
            <?php
                  }
  }
  

Share this post


Link to post
Share on other sites

×