Jump to content

Archived

This topic is now archived and is closed to further replies.

erin-wsk

Site Stalling on VPS with Caching

Recommended Posts

erin-wsk

Hey Guys, 

 

I've come upon a rather large issue and after a week or so of trying to work it out, all signs point back to DMS. This client, who was originally on shared hosting, bumped up to a VPS with Total Cache in place. She hired an outside developer to handle the transition and performance tune the server. After a week, the site seemed stable but as we found out, would stall at which point the php5-fpm processes were using a ton of CPU.

 

The issue became so large that I was forced to roll back to the original theme for the time being. The old theme loads at speed, exceptionally in fact, without issue. So my question, is why, when I implement Pagelines and plug-ins that are recommended/come with it (Simple Image Sizes, UberMenu, Custom Sidebars, + WP-PageNavi), the site becomes unstable? We were also seeing occasional errors in the log request varios core-css files from the /uploads/pagelines/ files.

 

I understand it's harder to diagnose the issue when the theme isn't installed, but it wasn't working. This also happens to be the same client that had her Pagelines upload folder reach over 20g (and no, I'm not exaggerating, that was the number) because it was never rewriting, only adding. (the VPS fixed this issue, but this is how we started down the path).

 

Here's the stats on the configuration we have and I can provide more information as needed. The client sees, on average, 18,000 to 20,000 visitors to her site a day. 

 

The server itself:

  • 4gb memory
  • 60gb storage with SSD drives
  • 2 cores

Server software:

  • OS: Ubuntu 14.04 LTS
  • PHP 5.5.9
  • Nginx 1.6.0
  • Google Pagespeed 1.7.30.4
  • Varnish 3.0.5

Thanks. 

Share this post


Link to post
Share on other sites
Simon

So what sort of support are you requiring here?

 

Was DMS writing a css file?

Was it falling back to legacy mode?

Is varnish configured properly?

What settings were you using in W3 cache ( it has literally 1000s )

How was google pagespeed configured?

18,000 different users? or 18,000 pageviews?

Share this post


Link to post
Share on other sites
erin-wsk

The site sees 18,000+ visitors (not pageviews) and all I'm looking for is a point in the right direction as you noted, there are 1,000 of settings on total cache and even more on the server config. Since it seems to be a direct conflict with Pagelines and no other theme, someone might have an idea as to where the conflict is and instead of continuing to trial/error and hope for the best (while frustrating the client.) 

 

DMS is writing a css file but last time I checked there were about 40 files in the uploads folder and occasionally, the site, when loading, wouldn't pull in the styles. 

 

Site settings and screenshots can be found here for Varnish, Pagespeed, and Total Cache: https://www.dropbox.com/sh/1rnv8f34lp82fsa/AADTtqEQSfeZp6z_Dp70mLKSa 

 

Like I said, just looking for suggestions since this issue seems to be directly related to when we enable DMS. 

 

 

Share this post


Link to post
Share on other sites
Simon

The reason you sometimes get no css when you publish a page, is because varnish/w3 cache is serving the old page with the old css url.

There is an alternative css mode under advanced settings for users with misconfigured over aggressive caching.

Share this post


Link to post
Share on other sites
erin-wsk

Yes, it is aggressive caching but when there wasn't any caching and varnish wasn't turned on, the site wouldn't load at all. 

Share this post


Link to post
Share on other sites
Simon

Its a bit difficult to diagnose a server issue when its not online im afraid.

Share this post


Link to post
Share on other sites
erin-wsk

Okay, well we will try it again with the alternative CSS and see how it goes. 

Share this post


Link to post
Share on other sites
Simon

W3 cache *should* serve static html files, if thats setup right, and varnish should do the same.

 

If you can get the site online without W3 cache running, I can take a look.

 

pagelines.com runs fine on a VPS without ANY cache plugin, and trust me we get a ton of traffic, daily.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×