Jump to content

Archived

This topic is now archived and is closed to further replies.

jane

Error messages ; postpins and register_metatab

Recommended Posts

jane    6
jane

Hello,

 

I enabled wp_debug and got these error messages; what, if anything, should I do?

 

Notice: Undefined property: PostPins::$icon in .../wp-content/plugins/postpins/postpins.php on line 318

Notice: register_metatab is deprecated since version 1.2 of PageLines DMS! Use section_opts() instead. in ...wp-content/themes/dms/dms/includes/deprecated.php on line 272

Share this post


Link to post
Share on other sites
Simon    247
Simon
They are just notices, why did you enable debug?

Share this post


Link to post
Share on other sites
jane    6
jane

My host provider is trying to help me figure why I've been having so many issues so they suggested enabling debug. In doing so, the DMS editor no longer worked and those notices appeared. So now it's been disabled. 

 

I take it from your response that notices are not that important?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Notices can be ignored, they're just notices such as the one you mentioned in your post which informs you that something is using a deprecated function.

 

However, if you enable WP_DEBUG and the DMS visual editor isn't working, then there is something seriously wrong with your site, as the DMS editor/toolbar should still function with WP_DEBUG set to true.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jane    6
jane

Is there someone that would be able to look into this issue for me right away? I am willing to pay.

Share this post


Link to post
Share on other sites
Simon    247
Simon
Turn off wp debug
Why your host thinks enabling it on a site that already functioning is beyond me


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
jane    6
jane

I did. Ultimately, it looks like something is wrong though...maybe it's down to a plugin?

Share this post


Link to post
Share on other sites

  • Similar Content

    • Jennifer Conway
      By Jennifer Conway+
      I recently installed PostPins and it was working great until I accidentally deleted the section. When I added the section back onto the page (without changing a thing), the posts were separated by a significant gap. I tried removing my custom CSS, reinstalling the plugin, deactivating other plugins, refreshing the cache -- but nothing seems to work. Unfortunately, I was also unable to revert to the published site (although I had not published the the new layout). 
      The section is currently working on the published site (insatiablecuriosities.com). The mis-stacked section is shown in the attached image. 

    • Janardan
      By Janardan+
      I want to know - how to load POSTS/ARTICLES from SUBDOMAIN of same main domain to homepage sidebar of main domain with the help of PostPins section adding in right side of sidebar .. but, there are no option to load posts from sub domains posted articles? or can we add custom links? to this PostPins section to display articles/posts from subdomain to show on main domain right side sidebar area?
      Because; main domain have posts overused I want to display from sub domain post LINKS to sidebar with the PostPins section help.
      I hope you got my question.. Thanks!
    • MrFent
      By MrFent+
      When PostPins is active on a page, I get PHP warnings:
      Notice: Undefined property: PostPins::$icon in /www/wp-content/plugins/postpins/postpins.php on line 318 Notice: register_metatab is deprecated since version 1.2 of PageLines DMS! Use section_opts() instead. in /www/wp-content/themes/dms/dms/includes/deprecated.php on line 280
      It looks like PostPins is still using section_optionator() and should be using section_opts()
    • roryorr
      By roryorr+
      Hi guys, need some help aligning PostPins left using CSS?
      http://www.cabaritaoceanhealthretreat.com.au/specialised-retreats/
      Cheers!
      Rory
    • petere21
      By petere21+
      I want to change meta info in postpins blog Editor offers me to do it with shortcodes: 
      Use shortcodes to customize the meta information for these pins.
      But I ma not able to set it by right way
      for example if I want to chande meta to show tags what is the right syntax? 
      [the_tags] doesnt work
×