Jump to content

Archived

This topic is now archived and is closed to further replies.

glennyboy

Placeholder Mixin Usage for Search Input

Recommended Posts

glennyboy

Hi

 

I noted that there is a mixing for the CSS3 'Placeholder' property:-

.placeholder(@color: @placeholderText) {
  &:-moz-placeholder {
    color: @color;
  }
  &:-ms-input-placeholder {
    color: @color;
  }
  &::-webkit-input-placeholder {
    color: @color;
  }
}

...but I can't work out how to apply it. 

 

My search input is class 'searchfield' (based on pagelines_saerch_form without its class) so I added Mixin as :-

 

.searchfield {

.placeholder(black Search this site);

}

 

Nothing happens what am I doping wrong please.

 

Thanks

 

Glennyboy

Share this post


Link to post
Share on other sites
Simon

That mixin only accepts a color

 

.searchfield {
    .placeholder( #666 );
}

Share this post


Link to post
Share on other sites
glennyboy

Is there any way to change the default text of the DMS search field then?

Share this post


Link to post
Share on other sites
Simon
Yea 3 ways depending on whatever floats your boat ;)
  • Use jQuery to change the text..
    jQuery('.searchfield').attr('placeholder', 'w00t')


  • Use the PHP filter: pagelines_search_form
    add_filter( 'pagelines_search_form', function($search) { return str_replace( 'Search', 'W00t' ); } );


  • Create your own searchform.php in the child theme root and DMS will use that instead.

NB: I didnt test the filter, it was off the top of my head, but you get the idea.

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×