Jump to content

Archived

This topic is now archived and is closed to further replies.

mckdesign

FontAwesome versioning mix

Recommended Posts

mckdesign

Hey, guys. I see that 2.1 brought us FontAwesome 4.1. Super, but I ran a Pingdom test and the waterfall shows me that the CSS loaded up is 3.2.1 still -- which is pulled in from the PageLines Pro plugin. Shouldn't this be updated to v4.1?

 

In addition, the waterfall shows me that the webfont is being loaded twice. v4.1.0 is loaded from DMS theme directory, with v3.2.1 loaded from bootstrapcdn.com. Neither is a large load, but it just seems odd to load up both, and potential for conflict. It seems if the CSS ref is updated, it'll call on the correct version of the webfont at bootstrapcdn -- and eliminate the need for the font in my DMS theme folder.

 

 

Share this post


Link to post
Share on other sites
Simon

That CSS is meant for IE below v9. Ive just updated the plugin to add conditionals.

Share this post


Link to post
Share on other sites
mckdesign

Hi, Simon.

 

So I'll look for a Pro update soon in which 3.2.1 is served up for LT IE9 and 4.1 for anything else?

Share this post


Link to post
Share on other sites
Simon

No thats it, it only loads that stylesheet for ie8 to fix broken icons. Altho broken icons are the least of an an ie8 users problems ;)

Share this post


Link to post
Share on other sites
mckdesign

Tell me about it.

 

Okay, I'll keep an eye peeled for an update, then.

 

Thanks!

Share this post


Link to post
Share on other sites
mckdesign

Hey, Simon. Just a quick note, following up on this topic. I noted that IE8 is showing boxes for my Font Awesome icons. If I change line 39 in class.browsercss.php in the DMS Pro plug-in to use the 4.1.0 CSS, it now works for me in IE8.

 

Examples:

standard plug-in: http://mckessonideashare.com/

 

"hacked" plug-in: http://mckis.staging.wpengine.com/

 

sidebar on right has Font Awesome icons preceding text.

 

Seems to me that the CSS needs to match the FA fonts version for IE8, rather than use a retrograde. What's the best method to override that line in the plug-in, should PL not experience the same pattern I'm seeing? Just manually override like I did on my staging site?

 

 

Pro plug-in 1.7.1, DMS 2.1.4

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×