Jump to content

Archived

This topic is now archived and is closed to further replies.

carletto0282

Fire lazyload after modal loaded

Recommended Posts

carletto0282+    4
carletto0282

Hi guys,

 

I need I little bit of help to solve a jquery problem.

 

I load a vimeo iframe inside a modal.

I'm using lazyloadxt to lazyload videos and it works quite well but only on page scroll.

So when I click on the button and load the modal it doesn't load the video until I scoll the page.

I see trough bootstrap documentation ( http://getbootstrap.com/javascript/#modals ) that it should be possible to fire an action right after the modal is shown so I've trued something like

$('#myModal').on('shown.bs.modal', function (e) {
  $(".lazy").lazyloadXT();
})

but it isn't working.

Searching also trough the lazyload documentation ( https://github.com/ressio/lazy-load-xt ) I've tried 
$.lazyLoadXT.updateEvent = 'shown.bs.modal';

with no luck

 
Any suggestion?
Thanks
 
Carlo

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Carlo,

 

Unfortunately, we can not provide support for third part scripts or code. You will need to ask this question elsewhere such as Stack Overflow.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
carletto0282+    4
carletto0282

I understand but I thought bootstrap was quite an strong embedded elemnt of pagelines DMS... and I'm trying to take advantage of all dms features before fall upon every other resource. 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Yeah Bootstrap is an important part of DMS, but you need to be aware that DMS uses a heavily customized version of Bootstrap 2.x not Bootstrap 3.x. Also, we can not provide support to bootstrap code, you're trying to alter the way a modal appears, modals are Bootstrap code, which we can not provide support for.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • cas45
      By cas45+
      I am running a site based on PageLines Framework 2.5.0. I am making some changes to a current website and managed to find a script that will do what I want.:
       
      $(".vend-cat").each( function() {
          if ( $(this).find(".no-vendors").html() == '' ) {
                 $(this).hide();
          }
      } );
       
      I have tested it on jsfiddle and it works fine. It does however need to be adapted to work with jQuery for pagelines and wordpress. Any help or advice?
       
      Thanks
    • unifeyed
      By unifeyed+
      Hello there. 
      I am trying to have all the ® symbols throughout my website superscript without having to individually go to each symbol and wrap them in <sup> tags. There is quite a bit of them. I have the following code within the Custom Scripts, but it seems to cause issues with the Hamburger navigation, as it does not seem to work. Can you offer up some assistance? 

      <script>
      jQuery(document).ready(function() {
                 jQuery("body").html(
          jQuery("body").html().replace(/®/gi, '<sup>®</sup>').replace(/®/gi, '<sup>®</sup>')
         );
              });
      </script>
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • ketri
      By ketri
      Hi!

      I'm using a jQuery-plugin called Taeggie (http://taeggie.com/)

      It seems that it requires jQuery version that's later than what comes with WordPress (ver=1.11.3). 
      If I just copy-paste a new jQuery to the section where I use the plugin, it works. But it's probably a very bad idea to load jQuery two times. 

      Can I override the old version of jQuery in functions.php and use a new version like 1.9?  
      Does it have issues with Pagelines or WordPress in general? Why is the version of jQuery that's used with WordPress so old?

      Thank you!
    • Jesper
      By Jesper+
      Is there a way to create modal popups? It was possible ind DMS2
×