Jump to content

Archived

This topic is now archived and is closed to further replies.

jmad

DMS2 Code Validation and CSS Errors

Recommended Posts

jmad

Not sure if these should be one or two topics.  When I run a Markup Validation via http://validator.w3.org/ I see a number of errors and many warnings when using DMS.  These appear to be mainly related to sections and headings.  Am I doing something wrong in my layout, are these warnings going to impact search results on Google or other engines (doesn't seem to be), how do I resolve or do I need to?  Using other Themes/frameworks I might get a couple errors and a few warnings.  Compare madskydesign.com (DMS2) to madsky.wpengine.com.  Sites were nearly identical until I started using the WPE one as a test area.  

 

Also in the Inspector I get a considerable CSS warnings about Invalid CSS property declaration.  They all refer me back to DMS code not my custom CSS (compiled-css-core).  Is this what should be expected in DMS

 

 

 

 

Share this post


Link to post
Share on other sites
GetMeWebDesign

For someone to comment, it would be easiest if you could screenshot the errors messages with Jing or copy and paste here. As for CSS... add it to the paste bin http://forum.pagelines.com/pst/ and post a link back here


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
jmad

I didn't attach the screen shot from the validator because the number of errors is hard to capture in one shot or paste together in several.  If you run either of the urls through http://validator.w3.org it's easy to see the errors and compare or pull the dev window to see the CSS error.  

 

Here is the screen shot of the errors. 

 

http://screencast.com/t/L92GGNGzXzqp

 

http://screencast.com/t/6BBxQgPOi8UE

Share this post


Link to post
Share on other sites
GetMeWebDesign

OK... these errors can occur. Danny enlightened me to the fact that a CSS validator wont deal with nested LESS so an error can show, when in fact it will be fine as LESS (just not CSS). If it is core css then I dont think it is a problem, but you need one of the moderators to comment... they are the experts


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
jmad

Ahh..Ha...  that makes perfect sense.

Share this post


Link to post
Share on other sites
Danny

Actually, thats not correct. If you were to validate your CSS using the direct input option, then yes you would definitely receive errors or warning if you input LESS CSS. As the validator is for CSS only.

 

However, you're referring to the HTML output validator so the two are completely different.

 

The error you receive regarding the font, this is related to Google code not ours.

 

The error you receive regarding the button is your own HTML code and your error, you have button class, it should be class. Which is coming from the Textbox with your HTML.

 

https://cloudup.com/cNewINjEbKn

 

The warnings you receive are regarding not having any header tag in those sections. I will need to speak to our developers regarding this or you could just instead a header in each of your sectionss. However, this is just a warning, its the errors you need to worry about. Both of which are out of our control as far as I am concerned, one is related to your code and the other is related to Googles own code for inserting fonts. But I will bring this to the attention of our developers.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jmad

Thanks Danny.  It was the warnings that I was most curious about the Google font error always happens on most themes.  My error I have under control.  

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×